summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-09-11 16:30:54 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-09-11 16:30:54 +0000
commitc127f45b114570f9fdc6a382fd92d58ca0936d39 (patch)
tree6b1e243ff10d9b55cc3beb528a44fe70bd613bce /dev-db
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.tar.gz
gentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.tar.bz2
gentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.zip
Hidding passwords when requested in pkg_config().
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/mysql-4.0.25-r2.ebuild12
-rw-r--r--dev-db/mysql/mysql-4.0.26.ebuild12
-rw-r--r--dev-db/mysql/mysql-4.1.13-r1.ebuild10
-rw-r--r--dev-db/mysql/mysql-4.1.14.ebuild10
-rw-r--r--dev-db/mysql/mysql-5.0.12_beta.ebuild10
6 files changed, 33 insertions, 28 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 269601c34a85..957b2ed66573 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.230 2005/09/10 08:52:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.231 2005/09/11 16:30:54 vivo Exp $
+
+ 11 Sep 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.0.25-r2.ebuild,
+ mysql-4.0.26.ebuild, mysql-4.1.13-r1.ebuild, mysql-4.1.14.ebuild,
+ mysql-5.0.12_beta.ebuild:
+ Hidding passwords when requested in pkg_config().
10 Sep 2005; Aron Griffis <agriffis@gentoo.org> mysql-4.0.25-r2.ebuild:
Mark 4.0.25-r2 stable on alpha
diff --git a/dev-db/mysql/mysql-4.0.25-r2.ebuild b/dev-db/mysql/mysql-4.0.25-r2.ebuild
index feefabe20b92..d012b94bebac 100644
--- a/dev-db/mysql/mysql-4.0.25-r2.ebuild
+++ b/dev-db/mysql/mysql-4.0.25-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.14 2005/09/10 08:52:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.15 2005/09/11 16:30:54 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -366,13 +366,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "bug: avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
- einfo "Repeat the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd1 ; echo
+ einfo "Check the password"
+ read -rsp " >" pwd2 ; echo
- if (( "x$pwd1" != "x$pwd2" )) ; then
+ if [[ "x$pwd1" != "x$pwd2" ]] ; then
die "Passwords are not the same"
fi
diff --git a/dev-db/mysql/mysql-4.0.26.ebuild b/dev-db/mysql/mysql-4.0.26.ebuild
index f598040e7950..82780d267a2e 100644
--- a/dev-db/mysql/mysql-4.0.26.ebuild
+++ b/dev-db/mysql/mysql-4.0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.2 2005/09/09 11:42:28 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.3 2005/09/11 16:30:54 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -386,13 +386,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "bug: avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
- einfo "Repeat the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd1 ; echo
+ einfo "Check the password"
+ read -rsp " >" pwd2 ; echo
- if (( "x$pwd1" != "x$pwd2" )) ; then
+ if [[ "x$pwd1" != "x$pwd2" ]] ; then
die "Passwords are not the same"
fi
diff --git a/dev-db/mysql/mysql-4.1.13-r1.ebuild b/dev-db/mysql/mysql-4.1.13-r1.ebuild
index 5c3901324fd6..57044130a384 100644
--- a/dev-db/mysql/mysql-4.1.13-r1.ebuild
+++ b/dev-db/mysql/mysql-4.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.13-r1.ebuild,v 1.5 2005/08/29 12:55:19 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.13-r1.ebuild,v 1.6 2005/09/11 16:30:54 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -417,13 +417,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "Avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
+ read -rsp " >" pwd1 ; echo
einfo "Check the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd2 ; echo
- if (( pwd1 != pwd2 )) ; then
+ if [[ pwd1 != pwd2 ]] ; then
die "Passwords are not the same"
fi
diff --git a/dev-db/mysql/mysql-4.1.14.ebuild b/dev-db/mysql/mysql-4.1.14.ebuild
index b558d0d0185d..bcd6c6b4ee23 100644
--- a/dev-db/mysql/mysql-4.1.14.ebuild
+++ b/dev-db/mysql/mysql-4.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.2 2005/09/09 11:42:28 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.3 2005/09/11 16:30:54 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -473,13 +473,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "Avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
+ read -rsp " >" pwd1 ; echo
einfo "Check the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd2 ; echo
- if (( pwd1 != pwd2 )) ; then
+ if [[ pwd1 != pwd2 ]] ; then
die "Passwords are not the same"
fi
diff --git a/dev-db/mysql/mysql-5.0.12_beta.ebuild b/dev-db/mysql/mysql-5.0.12_beta.ebuild
index a44ad7477c16..1eac5a0d2a0a 100644
--- a/dev-db/mysql/mysql-5.0.12_beta.ebuild
+++ b/dev-db/mysql/mysql-5.0.12_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.3 2005/09/09 11:42:28 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.4 2005/09/11 16:30:54 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -480,13 +480,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "Avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
+ read -rsp " >" pwd1 ; echo
einfo "Check the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd2 ; echo
- if (( pwd1 != pwd2 )) ; then
+ if [[ pwd1 != pwd2 ]] ; then
die "Passwords are not the same"
fi