summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-09-15 16:50:14 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-09-15 16:50:14 +0000
commitcabd01f96a11f54795935705c8e81140364accc7 (patch)
treee66be636888e879ff9cf8b6de4fc7f08ac89691d /dev-db
parentFix build in non C locales, possibly fixes bug #227055, thank Evil Compile Pe... (diff)
downloadgentoo-2-cabd01f96a11f54795935705c8e81140364accc7.tar.gz
gentoo-2-cabd01f96a11f54795935705c8e81140364accc7.tar.bz2
gentoo-2-cabd01f96a11f54795935705c8e81140364accc7.zip
Version bump. Fixes bug #234414 and bug #237222. Can possibly break code building against sqlite, see upstream release notes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/sqlite-3.6.2.ebuild87
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 38b889bc10bc..985f1487597a 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.199 2008/08/05 16:54:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.200 2008/09/15 16:50:14 betelgeuse Exp $
+
+*sqlite-3.6.2 (15 Sep 2008)
+
+ 15 Sep 2008; Petteri Räty <betelgeuse@gentoo.org> +sqlite-3.6.2.ebuild:
+ Version bump. Fixes bug #234414 and bug #237222. Can possibly break code
+ building against sqlite, see upstream release notes.
05 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/dev-db/sqlite/sqlite-3.6.2.ebuild b/dev-db/sqlite/sqlite-3.6.2.ebuild
new file mode 100644
index 000000000000..07c4a65d786d
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.6.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.2.ebuild,v 1.1 2008/09/15 16:50:14 betelgeuse Exp $
+
+EAPI="1"
+
+inherit versionator eutils flag-o-matic libtool
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+DOC_PV=$(replace_all_version_separators _)
+SRC_URI="http://www.sqlite.org/${P}.tar.gz
+ doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+pkg_setup() {
+ # test
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # not available via configure and requested in bug #143794
+ use soundex && append-flags -DSQLITE_SOUNDEX=1
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl) \
+ || die
+ emake all || die "emake all failed"
+}
+
+src_test() {
+ if has userpriv ${FEATURES}; then
+ local test=test
+ use debug && tets=fulltest
+ emake ${test} || die "some test(s) failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install \
+ || die "emake install failed"
+
+ doman sqlite3.1 || die
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/${PN}_docs_${DOC_PV}/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "sqlite-3.6.0 is not totally backwards compatible, see"
+ elog "http://www.sqlite.org/releaselog/3_6_0.html for full details."
+}