summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-12-09 14:10:16 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-12-09 14:10:16 +0000
commitcd781e952346fdebf0a06ac5d75fea84725c3be6 (patch)
tree42b64fe94d033f374bd268a06095737607f251f7 /dev-db
parentStable on ppc wrt bug 157353 (diff)
downloadgentoo-2-cd781e952346fdebf0a06ac5d75fea84725c3be6.tar.gz
gentoo-2-cd781e952346fdebf0a06ac5d75fea84725c3be6.tar.bz2
gentoo-2-cd781e952346fdebf0a06ac5d75fea84725c3be6.zip
Revision bump: Remove redundant deps, make it respect LDFLAGS and add ~x86-fbsd keyword
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/cdb/ChangeLog8
-rw-r--r--dev-db/cdb/cdb-0.75-r2.ebuild56
-rw-r--r--dev-db/cdb/files/digest-cdb-0.75-r23
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-db/cdb/ChangeLog b/dev-db/cdb/ChangeLog
index 5128d95783f4..eaa7811ca611 100644
--- a/dev-db/cdb/ChangeLog
+++ b/dev-db/cdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/cdb
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.31 2006/11/22 18:45:04 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.32 2006/12/09 14:10:16 drizzt Exp $
+
+*cdb-0.75-r2 (09 Dec 2006)
+
+ 09 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> +cdb-0.75-r2.ebuild:
+ Revision bump: Remove redundant deps, make it respect LDFLAGS and add
+ ~x86-fbsd keyword
22 Nov 2006; Charlie Shepherd <masterdriverz@gentoo.org> ChangeLog:
Add blocker with dev-db/freecdb, thanks to Tuan Van for reporting, bug 115594
diff --git a/dev-db/cdb/cdb-0.75-r2.ebuild b/dev-db/cdb/cdb-0.75-r2.ebuild
new file mode 100644
index 000000000000..03137d651c54
--- /dev/null
+++ b/dev-db/cdb/cdb-0.75-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r2.ebuild,v 1.1 2006/12/09 14:10:16 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
+HOMEPAGE="http://cr.yp.to/cdb.html"
+SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4
+ !dev-db/freecdb"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-errno.diff
+
+ sed -i \
+ -e 's/head -1/head -n 1/g' Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
+ die "dobin failed"
+
+ # ok so.. first off, some automakes fail at not finding
+ # cdb.a, so install that
+ dolib *.a || die
+
+ # then do this pretty little symlinking to solve the somewhat
+ # cosmetic library issue at hand
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+
+ # uint32.h needs installation too, otherwise compiles depending
+ # on it will fail
+ insinto /usr/include
+ doins cdb*.h buffer.h alloc.h uint32.h || die "doins failed"
+
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+}
diff --git a/dev-db/cdb/files/digest-cdb-0.75-r2 b/dev-db/cdb/files/digest-cdb-0.75-r2
new file mode 100644
index 000000000000..c987a0d3c784
--- /dev/null
+++ b/dev-db/cdb/files/digest-cdb-0.75-r2
@@ -0,0 +1,3 @@
+MD5 81fed54d0bde51b147dd6c20cdb92d51 cdb-0.75.tar.gz 54162
+RMD160 d52288ee6df58fdc5a79efc16693cd5e305f9c65 cdb-0.75.tar.gz 54162
+SHA256 1919577799a50c080a8a05a1cbfa5fa7e7abc823d8d7df2eeb181e624b7952c5 cdb-0.75.tar.gz 54162