summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-04-15 12:52:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-04-15 12:52:25 +0000
commitce0db39d2b1ee0d8ca846bd7c9a77a5747085367 (patch)
tree481918559764f2e564695e48486963106af4d0de /dev-db
parentStable on ppc wrt bug 174404 (diff)
downloadgentoo-2-ce0db39d2b1ee0d8ca846bd7c9a77a5747085367.tar.gz
gentoo-2-ce0db39d2b1ee0d8ca846bd7c9a77a5747085367.tar.bz2
gentoo-2-ce0db39d2b1ee0d8ca846bd7c9a77a5747085367.zip
Version bump, for two security bugs: #171934 and #170126.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/files/digest-mysql-5.0.386
-rw-r--r--dev-db/mysql/mysql-5.0.38.ebuild75
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index d28e0fdedebe..fa56924043c5 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.390 2007/03/06 16:11:48 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.391 2007/04/15 12:52:25 robbat2 Exp $
+
+*mysql-5.0.38 (15 Apr 2007)
+
+ 15 Apr 2007; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.38.ebuild:
+ Version bump, for two security bugs: #171934 and #170126.
06 Mar 2007; Luca Longinotti <chtekk@gentoo.org> mysql-5.0.34.ebuild:
Port libtool fix properly to mysql.eclass.
diff --git a/dev-db/mysql/files/digest-mysql-5.0.38 b/dev-db/mysql/files/digest-mysql-5.0.38
new file mode 100644
index 000000000000..6e7dbacea0ae
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-5.0.38
@@ -0,0 +1,6 @@
+MD5 9abf789eb57b7c21294ae50eb4a94462 mysql-5.0.38.tar.gz 23307140
+RMD160 7c69373e4c3de1d04b3494890d43ee61f49ce3de mysql-5.0.38.tar.gz 23307140
+SHA256 c8a4e746a1465b1768c356713b0e0b62818eb5132c8bb674747dabc5f37786c4 mysql-5.0.38.tar.gz 23307140
+MD5 c93af0ab37b79b31545f0dce5e02103d mysql-extras-20070415.tar.bz2 51424
+RMD160 8babddf636b175cc044cbc821ab64e62eedcb6ce mysql-extras-20070415.tar.bz2 51424
+SHA256 cbaed8e7e35899417d3e265798f4f9ffd046af99f4032b38b114c36b6887a704 mysql-extras-20070415.tar.bz2 51424
diff --git a/dev-db/mysql/mysql-5.0.38.ebuild b/dev-db/mysql/mysql-5.0.38.ebuild
new file mode 100644
index 000000000000..5cb31c17b6a8
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.38.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.38.ebuild,v 1.1 2007/04/15 12:52:25 robbat2 Exp $
+
+MY_EXTRAS_VER="20070415"
+SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
+
+inherit mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ if ! hasq "userpriv" ${FEATURES} ; then
+ mysql_disable_test "im_daemon_life_cycle" "fails as root"
+ mysql_disable_test "im_life_cycle" "fails as root"
+ mysql_disable_test "im_options_set" "fails as root"
+ mysql_disable_test "im_options_unset" "fails as root"
+ mysql_disable_test "im_utils" "fails as root"
+ fi
+
+ # As of 5.0.38, these work with the sandbox
+ # Tested by robbat2, on ppc64-32ul and amd64.
+ ##for t in \
+ ##loaddata_autocom_ndb \
+ ##ndb_{alter_table{,2},autodiscover{,2,3},basic,bitfield,blob} \
+ ##ndb_{cache{,2},cache_multi{,2},charset,condition_pushdown,config} \
+ ##ndb_{database,gis,index,index_ordered,index_unique,insert,limit} \
+ ##ndb_{loaddatalocal,lock,minmax,multi,read_multi_range,rename,replace} \
+ ##ndb_{restore,subquery,transaction,trigger,truncate,types,update} \
+ ##ps_7ndb rpl_ndb_innodb_trans strict_autoinc_5ndb \
+ ##mysql_upgrade
+ ##do
+ ## mysql_disable_test "${t}" "fails with sandbox enabled"
+ ##done
+
+ # Both of these seem to work as of 5.0.38
+ ##use "extraengine" && mysql_disable_test "federated" "fails with extraengine USE"
+ ##use "ssl" && mysql_disable_test "ssl_des" "fails requiring PEM passphrase"
+
+ # Revisit after 5.0.38
+ [ "${PV}" == "5.0.38" ] && use "extraengine" && mysql_disable_test "archive_gis" "fails with extraengine USE"
+
+ # We run the test protocols seperately
+ make test-ns force=--force
+ retstatus1=$?
+
+ [ "${PV}" == "5.0.38" ] && mysql_disable_test "errors" "fails under the PS protocol"
+ make test-ps force=--force
+ retstatus2=$?
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}