summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-19 10:58:56 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-19 10:58:56 +0000
commitd695899dfd29a8c39b0761d98a38d9946822ce7f (patch)
tree858aac445597223c83dce503b332cfa2aab52155 /dev-db
parent+firebird (diff)
downloadgentoo-2-d695899dfd29a8c39b0761d98a38d9946822ce7f.tar.gz
gentoo-2-d695899dfd29a8c39b0761d98a38d9946822ce7f.tar.bz2
gentoo-2-d695899dfd29a8c39b0761d98a38d9946822ce7f.zip
sh love
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/cdb/cdb-0.75-r1.ebuild18
-rw-r--r--dev-db/cdb/cdb-0.75.ebuild5
2 files changed, 12 insertions, 11 deletions
diff --git a/dev-db/cdb/cdb-0.75-r1.ebuild b/dev-db/cdb/cdb-0.75-r1.ebuild
index 1c14c80bd80e..de8f8e1800ab 100644
--- a/dev-db/cdb/cdb-0.75-r1.ebuild
+++ b/dev-db/cdb/cdb-0.75-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r1.ebuild,v 1.1 2005/12/15 16:37:51 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r1.ebuild,v 1.2 2006/01/19 10:58:56 vapier Exp $
inherit eutils toolchain-funcs
@@ -10,18 +10,19 @@ SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""
DEPEND=">=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
app-arch/tar
app-arch/gzip"
+RDEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-errno.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-errno.diff
sed -i \
-e 's/head -1/head -n 1/g' Makefile || \
@@ -41,17 +42,16 @@ src_install() {
# ok so.. first off, some automakes fail at not finding
# cdb.a, so install that
- dolib *.a
+ dolib *.a || die
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym /usr/$(get_libdir)/cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
insinto /usr/include
doins cdb*.h buffer.h alloc.h uint32.h || die "doins failed"
- dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION || \
- die "dodoc failed"
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
}
diff --git a/dev-db/cdb/cdb-0.75.ebuild b/dev-db/cdb/cdb-0.75.ebuild
index 270af359fd41..244228f69d29 100644
--- a/dev-db/cdb/cdb-0.75.ebuild
+++ b/dev-db/cdb/cdb-0.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.28 2006/01/18 20:05:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.29 2006/01/19 10:58:56 vapier Exp $
inherit eutils toolchain-funcs
@@ -10,13 +10,14 @@ SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ~ppc-macos ppc64 s390 ~sparc x86"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc-macos ppc64 s390 sh ~sparc x86"
IUSE=""
DEPEND=">=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
app-arch/tar
app-arch/gzip"
+RDEPEND=""
src_unpack() {
unpack ${A}