summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-12-19 01:42:37 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-12-19 01:42:37 +0000
commite91ac3080daf71a7e024a14af89cdbb8254e3abe (patch)
tree40fa609530e362803581c51211b013d631648316 /dev-db
parentinitial version (diff)
downloadgentoo-2-e91ac3080daf71a7e024a14af89cdbb8254e3abe.tar.gz
gentoo-2-e91ac3080daf71a7e024a14af89cdbb8254e3abe.tar.bz2
gentoo-2-e91ac3080daf71a7e024a14af89cdbb8254e3abe.zip
Version bump.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog8
-rw-r--r--dev-db/postgresql/Manifest2
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.3.54
-rw-r--r--dev-db/postgresql/files/postgresql.init-7.3.555
-rw-r--r--dev-db/postgresql/postgresql-7.3.5.ebuild243
5 files changed, 311 insertions, 1 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index a44dce75dd84..df1846fb1f80 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.73 2003/12/19 00:59:14 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.74 2003/12/19 01:42:37 nakano Exp $
+
+*postgresql-7.3.5 (19 Dec 2003)
+
+ 19 Dec 2003; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.5.ebuild,
+ files/postgresql.init-7.3.5:
+ Version bump.
*postgresql-7.4-r1 (25 Nov 2003)
19 Dec 2003; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.4-r1.ebuild,
diff --git a/dev-db/postgresql/Manifest b/dev-db/postgresql/Manifest
index 93f986d3fc18..947665f0f48e 100644
--- a/dev-db/postgresql/Manifest
+++ b/dev-db/postgresql/Manifest
@@ -1,7 +1,9 @@
MD5 6a0aaf5f7fb04f3fe2e577bf967e2230 ChangeLog 12124
MD5 c618574d1288cc0cdc40dcbdbae5be9e postgresql-7.3.4-r1.ebuild 8001
+MD5 7fdde2c4d03fe67c55fd739a1751e449 postgresql-7.3.5.ebuild 8242
MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
MD5 6831821042e1bfa1877540320d7a2278 postgresql-7.4-r1.ebuild 7821
+MD5 7b4771ec5dd5bcb3f47495cca2fb3482 files/digest-postgresql-7.3.5 288
MD5 b0b26f2f466f14fcab3085e2ce726413 files/postgresql.init-7.3.4 1138
MD5 2b0c84d2c26622573d4e2b7e0518fdad files/postgresql.conf 375
MD5 4e148f930c09bddec23d157f9c446020 files/postgresql.init 937
diff --git a/dev-db/postgresql/files/digest-postgresql-7.3.5 b/dev-db/postgresql/files/digest-postgresql-7.3.5
new file mode 100644
index 000000000000..df4394a2c3a1
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.3.5
@@ -0,0 +1,4 @@
+MD5 071efb8cee72a62b4f0da478df39f08d postgresql-base-7.3.5.tar.bz2 5645560
+MD5 d106ee6a4b0fb1d63eb51525ee8faed6 postgresql-opt-7.3.5.tar.bz2 340898
+MD5 7354a7c9cc5f1203586131e454df270e postgresql-docs-7.3.5.tar.bz2 2336586
+MD5 0081cb994e22f6af83f1984fdaeed16e hier-Pg7.3-0.4.tar.gz 33264
diff --git a/dev-db/postgresql/files/postgresql.init-7.3.5 b/dev-db/postgresql/files/postgresql.init-7.3.5
new file mode 100644
index 000000000000..9ea516e3e0bb
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.init-7.3.5
@@ -0,0 +1,55 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.rc6,v 1.1 2002/01/06 00:53:24 woodchip Exp
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -d $PGDATA ]; then
+ eerror "directory not found: $PGDATA"
+ eerror "You should create PGDATA directory first."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting postgres"
+ if [ -f $PGDATA/postmaster.pid ]; then
+ rm $PGDATA/postmaster.pid
+ fi
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "$PGDATA/postmaster.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $PGLOG"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop () {
+ ebegin "Stopping postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart () {
+ ebegin "Restarting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
diff --git a/dev-db/postgresql/postgresql-7.3.5.ebuild b/dev-db/postgresql/postgresql-7.3.5.ebuild
new file mode 100644
index 000000000000..ff8952e12d07
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.3.5.ebuild
@@ -0,0 +1,243 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.5.ebuild,v 1.1 2003/12/19 01:42:37 nakano Exp $
+
+DESCRIPTION="sophisticated Object-Relational DBMS"
+
+RESTRICT="nomirror"
+P_HIERPG="hier-Pg7.3-0.4"
+HOMEPAGE="http://www.postgresql.org/ http://gppl.terminal.ru/index.eng.html"
+SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
+ mirror://postgresql/source/v${PV}/${PN}-opt-${PV}.tar.bz2
+ doc? ( mirror://postgresql/source/v${PV}/${PN}-docs-${PV}.tar.bz2 )
+ pg-hier? ( http://gppl.terminal.ru/${P_HIERPG}.tar.gz )"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~hppa"
+IUSE="ssl nls java python tcltk perl libg++ pam readline zlib pg-hier"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ app-admin/sudo
+ >=sys-libs/ncurses-5.2
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( !ppc? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+# java dep workaround for portage bug
+# x86? ( java? ( =dev-java/sun-jdk-1.3* >=dev-java/ant-1.3 ) )
+RDEPEND="virtual/glibc
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( !ppc? ( >=dev-lang/python-2.2 ) )
+ java? ( !amd64? ( >=virtual/jdk-1.3* ) )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+PG_DIR="/var/lib/postgresql"
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ die
+ fi
+ fi
+
+ if [ "`use java`" ]; then
+ if [ "`use amd64`" -o "`use hppa`" ]; then
+ ewarn "Ignore USE=\"java\" in amd64/hppa"
+ fi
+ fi
+
+ if [ "`use python`" ]; then
+ if [ "`use ppc`" ]; then
+ ewarn "Ignore USE=\"python\" in ppc"
+ fi
+ fi
+}
+
+check_java_config() {
+ JDKHOME="`java-config --jdk-home`"
+ if [ -z "${JDKHOME}" ] || [ ! -d "${JDKHOME}" ]; then
+ NOJDKERROR="You need to use java-config to set your JVM to a JDK!"
+ eerror "${NOJDKERROR}"
+ die "${NOJDKERROR}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A} || die
+ if [ "`use pg-hier`" ]; then
+ cd ${WORKDIR} || die
+ mv readme.html README-${P_HIERPG}.html || die
+ cd ${S} || die
+ epatch ${WORKDIR}/${P_HIERPG}.diff || die
+ fi
+ cd ${S} || die
+}
+
+src_compile() {
+ filter-flags -ffast-math
+
+ use java && use amd64 || use hppa || check_java_config
+
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && use ppc || myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use java && use amd64 || use hppa || myconf="$myconf --with-java"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-nls"
+ use libg++ && myconf="$myconf --with-CXX"
+ use pam && myconf="$myconf --with-pam"
+ use readline || myconf="$myconf --without-readline"
+ use zlib || myconf="$myconf --without-zlib"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-maxbackends=1024 \
+ $myconf || die
+
+ make || die
+ cd contrib
+ make || die
+}
+
+src_install() {
+ addwrite "/usr/share/man/man3/Pg.3pm"
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}
+ if [ "`use pg-hier`" ]; then
+ dodoc ${WORKDIR}/README-${P_HIERPG}.html
+ fi
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ dodoc contrib/adddepend/*
+
+ if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ fi
+
+ dodir /usr/include/postgresql/pgsql
+ cp ${D}/usr/include/*.h ${D}/usr/include/postgresql/pgsql
+
+ cd ${S}/doc
+ dodoc FAQ* README.* TODO bug.template
+ if [ "`use doc`" ]; then
+ cd ${S}/doc
+ docinto FAQ_html || die
+ dodoc src/FAQ/* || die
+ docinto sgml || die
+ dodoc src/sgml/*.{sgml,dsl} || die
+ docinto sgml/ref || die
+ dodoc src/sgml/ref/*.sgml || die
+ docinto TODO.detail || die
+ dodoc TODO.detail/* || die
+ fi
+
+ cd ${S}
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/postgresql.init-${PV} postgresql || die
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/postgresql.conf postgresql || die
+}
+
+pkg_postinst() {
+ einfo "Execute the following command"
+ einfo "ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo "to setup the initial database environment."
+ einfo ""
+ einfo "Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell, or /bin/true"
+}
+
+pkg_config() {
+ einfo "Creating the data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres:postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo "Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ die
+ else
+ einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
+ einfo "Read the documentation to check how to upgrade to version ${PV}."
+ fi
+ else
+ # On hppa, postgresql need way more than the default sem index and shmmax
+ if [ "${ARCH}" = "hppa" ]; then
+ SEM_IDX_MIN=1024
+ SHMMAX_MIN=100000000
+ SEM_IDX=`sysctl kernel.sem | awk '{ print $6 }'`
+ if [ $SEM_IDX -lt ${SEM_IDX_MIN} ]; then
+ eerror "The last value of /proc/sys/kernel/sem is too low for postgresql to run"
+ eerror "Temporary setting this value to ${SEM_IDX_MIN} while creating the initial database."
+ cat /proc/sys/kernel/sem | sed -e "s/\t${SEM_IDX}/\t${SEM_IDX_MIN}/" > /proc/sys/kernel/sem
+ fi
+ fi
+ sudo -u postgres /usr/bin/initdb --pgdata ${PG_DIR}/data
+
+ if [ "${ARCH}" = "hppa" ]; then
+ if [ ! `sysctl kernel.sem | awk '{ print $6 }'` -eq ${SEM_IDX} ] ; then
+ cat /proc/sys/kernel/sem | sed -e "s/\t${SEM_IDX_MIN}/\t${SEM_IDX}/" > /proc/sys/kernel/sem
+ ewarn "Restoring the sem idx value to the previous value"
+ ewarn "Please edit the last value of kernel.sem in /etc/sysctl.conf"
+ ewarn "and set it to at least ${SEM_IDX_MIN}"
+ fi
+
+ if [ `sysctl kernel.shmmax | awk '{ print $3 }'` -lt ${SHMMAX_MIN} ]; then
+ eerror "The current value of /proc/sys/kernel/shmmax is too low"
+ eerror "for postgresql to run. Please edit /etc/sysctl.conf and set"
+ eerror "this value to at least ${SHMMAX_MIN}."
+
+ fi
+ fi
+
+ einfo "If you are upgrading from a pre-7.3 version of PostgreSQL, please read"
+ einfo "the README.adddepend file for information on how to properly migrate"
+ einfo "all serial columns, unique keys and foreign keys to this version."
+ fi
+}