summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-02-15 16:22:13 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-02-15 16:22:13 +0000
commite9b9c3db2ec891fb9ad40f1d0334cc511cf6a90a (patch)
treeadba9fc10bbff97569e38af803081b2ee400e5f6 /dev-db
parentremoved flawed versions that create a corrupt portage tree (diff)
downloadgentoo-2-e9b9c3db2ec891fb9ad40f1d0334cc511cf6a90a.tar.gz
gentoo-2-e9b9c3db2ec891fb9ad40f1d0334cc511cf6a90a.tar.bz2
gentoo-2-e9b9c3db2ec891fb9ad40f1d0334cc511cf6a90a.zip
version upgrade
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog9
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.21
-rw-r--r--dev-db/postgresql/files/postgresql-7.2-dyn-libperl-gentoo.diff39
-rw-r--r--dev-db/postgresql/postgresql-7.2.ebuild144
4 files changed, 192 insertions, 1 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index d4b25dc4190a..cc2b1181b31a 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.3 2002/02/05 10:38:14 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.4 2002/02/15 16:22:09 gbevin Exp $
+
+*postgresql-7.2 (15 Feb 2002)
+
+ 15 Feb 2002; G.Bevin <gbevin@gentoo.org> postgresql-7.2.ebuild ,
+ files/postgresql-7.2-dyn-libperl-gentoo.diff files/digest-postgresql-7.2:
+ Upgraded to version 7.2. Python now also works with python 2.2 and there
+ are less patches needed to make the perl install go smoothly ... nice :-)
*postgresql-7.1.3-r4 (5 Feb 2002)
diff --git a/dev-db/postgresql/files/digest-postgresql-7.2 b/dev-db/postgresql/files/digest-postgresql-7.2
new file mode 100644
index 000000000000..c0daa65f8ba7
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.2
@@ -0,0 +1 @@
+MD5 4174777cd91f3cc96f91efb2e4e1bc7c postgresql-7.2.tar.gz 9180168
diff --git a/dev-db/postgresql/files/postgresql-7.2-dyn-libperl-gentoo.diff b/dev-db/postgresql/files/postgresql-7.2-dyn-libperl-gentoo.diff
new file mode 100644
index 000000000000..6b6b57a45051
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-7.2-dyn-libperl-gentoo.diff
@@ -0,0 +1,39 @@
+--- postgresql-7.2/src/pl/plperl/Makefile.PL_orig 2002-02-15 16:59:00.000000000 +0100
++++ postgresql-7.2/src/pl/plperl/Makefile.PL 2002-02-15 16:59:23.000000000 +0100
+@@ -3,36 +3,6 @@
+ use DynaLoader;
+ use Config;
+
+-# On some platforms you can't build plperl unless libperl is a shared
+-# library. (Actually, it would be enough if code in libperl.a is
+-# compiled to be position-independent, but that is hard to check for
+-# and seems pretty unlikely anyway.) On some platforms it doesn't
+-# matter and they can pass in the --force flag to build anyway.
+-# (Having a shared libperl is still a lot better for efficiency,
+-# though.)
+-
+-if ($Config{'useshrplib'} ne 'true' && $ARGV[0] ne '--force') {
+- open(OUT, ">Makefile") or die "Can't write Makefile: $!\n";
+- print OUT <<'EndOfMakefile';
+-# Dummy Makefile for use when we can't build plperl
+-
+-all:
+- @echo ""; \
+- echo "*** Cannot build PL/Perl because libperl is not a shared library." ; \
+- echo "*** You might have to rebuild your Perl installation. Refer to"; \
+- echo "*** the documentation for details."; \
+- echo ""
+-
+-install:
+-
+-clean realclean:
+- rm -f Makefile
+-
+-EndOfMakefile
+- close(OUT);
+- exit(0);
+-}
+-
+ my $ldopts=ldopts();
+ $ldopts=~s/$Config{ccdlflags}//;
+
diff --git a/dev-db/postgresql/postgresql-7.2.ebuild b/dev-db/postgresql/postgresql-7.2.ebuild
new file mode 100644
index 000000000000..d6e8d47f0154
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.ebuild,v 1.1 2002/02/15 16:22:10 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.easynet.be/postgresql/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.postgresql.org"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3 >=dev-java/ant-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+SLOT="0"
+
+src_unpack() {
+
+ unpack postgresql-${PV}.tar.gz
+
+ cd ${S}
+
+ # we know that a shared libperl is present, the default perl
+ # config is however set to the static libperl.a
+ # just remove the check
+ patch -p1 < ${FILESDIR}/${P}-dyn-libperl-gentoo.diff || die
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcltk`" ]
+ then
+ myconf="--with-tcl"
+ fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --with-python"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --with-perl"
+ fi
+ if [ "`use java`" ]
+ then
+ myconf="$myconf --with-java"
+ fi
+ if [ "`use ssl`" ]
+ then
+ myconf="$myconf --with-openssl=/usr"
+ fi
+ if [ "`use nls`" ]
+ then
+ myconf="$myconf --enable-locale"
+ fi
+ if [ "`use libg++`" ]
+ then
+ myconf="$myconf --with-CXX"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ $myconf || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ cd ${S}/doc
+ dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
+ dodoc TODO internals.ps bug.template
+ dodoc *.tar.gz
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto sgml/graphics
+ dodoc src/graphics/*
+ rm -rf ${D}/usr/doc ${D}/mnt
+ exeinto /usr/bin
+
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/${PV}/${PN}
+
+ einfo ">>> Execute the following command"
+ einfo ">>> ebuild /var/db/pkg/dev-db/${P}/${P}.ebuild config"
+ einfo ">>> to setup the initial database environment."
+}
+
+
+pkg_config() {
+
+ einfo ">>> Creating data directory ..."
+ mkdir -p /var/lib/postgresql/data
+ chown -Rf postgres.postgres /var/lib/postgresql
+ chmod 700 /var/lib/postgresql/data
+
+ einfo ">>> Initializing the database ..."
+ if [ -f /var/lib/postgresql/data/PG_VERSION ] ; then
+ echo -n "A postgres data directory already exists from version "; cat /var/lib/postgresql/data/PG_VERSION
+ echo "Read the documentation to check how to upgrade to version ${PV}."
+ else
+ su - postgres -c "/usr/bin/initdb --pgdata /var/lib/postgresql/data"
+ fi
+
+}