summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-31 21:16:44 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-31 21:16:44 +0000
commiteb6f90245de25a4caf73e1c9ce13266e4c702173 (patch)
tree5c77dcfa6133494d285af19e08df0760cbcd4c19 /dev-db
parentnew minor upstream release (diff)
downloadgentoo-2-eb6f90245de25a4caf73e1c9ce13266e4c702173.tar.gz
gentoo-2-eb6f90245de25a4caf73e1c9ce13266e4c702173.tar.bz2
gentoo-2-eb6f90245de25a4caf73e1c9ce13266e4c702173.zip
Version Bump. Fixes #8895. Arch mask x86
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tora/ChangeLog8
-rw-r--r--dev-db/tora/files/digest-tora-1.3.81
-rw-r--r--dev-db/tora/tora-1.3.8.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index b6319c646c94..bf6e65e25fb3 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tora
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.2 2002/08/19 00:08:53 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.3 2002/10/31 21:16:44 rphillips Exp $
+
+*tora-1.3.8 (31 Oct 2002)
+
+ 31 Oct 2002; Ryan Phillips <rphillips@gentoo.org> :
+ Version bump
+ x86 Masked
*tora-1.3.7 (18 Aug 2002)
diff --git a/dev-db/tora/files/digest-tora-1.3.8 b/dev-db/tora/files/digest-tora-1.3.8
new file mode 100644
index 000000000000..995bd22e34ac
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.8
@@ -0,0 +1 @@
+MD5 400231fde03379426ee6f316112c8823 tora-alpha-1.3.8.tar.gz 2377390
diff --git a/dev-db/tora/tora-1.3.8.ebuild b/dev-db/tora/tora-1.3.8.ebuild
new file mode 100644
index 000000000000..cf938cb43a7b
--- /dev/null
+++ b/dev-db/tora/tora-1.3.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.8.ebuild,v 1.1 2002/10/31 21:16:44 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TOra - Toolkit For Oracle"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+HOMEPAGE="http://www.globecom.se/tora/"
+DEPEND=">=x11-libs/qt-3.0.0
+ mysql? ( >=dev-db/mysql-3.23 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myconf
+
+ use kde && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use mysql && myconf="$myconf" \
+ || myconf="$myconf --without-mysql"
+# use postgres && myconf="$myconf" \
+# || myconf="$myconf --without-postgres"
+ use oci8 && myconf="$myconf" \
+ || myconf="$myconf --without-oracle"
+
+ #patch -p0 < ${FILESDIR}/tora-${PV}.patch
+
+ ./configure \
+ --prefix=/usr \
+ --with-mono \
+ $myconf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ make \
+ ROOT=${D} \
+ install || die "make install failed"
+}
+
+pkg_setup () {
+
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}