summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-09 18:04:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-09 18:04:17 +0000
commitf685e8353870146088d9de9a6a8217b70bb175e8 (patch)
treec48b763817b5ff3ababed4d6e6ad7550a51e6d86 /dev-db
parentFix building with x11-libs/libnotify >= 0.7 wrt #354133 by Diego Elio Pettenò. (diff)
downloadgentoo-2-f685e8353870146088d9de9a6a8217b70bb175e8.tar.gz
gentoo-2-f685e8353870146088d9de9a6a8217b70bb175e8.tar.bz2
gentoo-2-f685e8353870146088d9de9a6a8217b70bb175e8.zip
Set SUPPORT_PYTHON_ABIS (bug #312141).
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pygresql/ChangeLog6
-rw-r--r--dev-db/pygresql/pygresql-3.8.1.ebuild26
2 files changed, 20 insertions, 12 deletions
diff --git a/dev-db/pygresql/ChangeLog b/dev-db/pygresql/ChangeLog
index abadebd5498a..89ca5116b62d 100644
--- a/dev-db/pygresql/ChangeLog
+++ b/dev-db/pygresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/pygresql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.50 2011/01/08 16:18:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.51 2011/02/09 18:04:17 arfrever Exp $
+
+ 09 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pygresql-3.8.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #312141).
08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pygresql-4.0.ebuild:
diff --git a/dev-db/pygresql/pygresql-3.8.1.ebuild b/dev-db/pygresql/pygresql-3.8.1.ebuild
index e6b9f9a5c4e2..58c232ba4463 100644
--- a/dev-db/pygresql/pygresql-3.8.1.ebuild
+++ b/dev-db/pygresql/pygresql-3.8.1.ebuild
@@ -1,36 +1,40 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.8.1.ebuild,v 1.9 2011/01/08 16:08:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.8.1.ebuild,v 1.10 2011/02/09 18:04:17 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils distutils
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+inherit distutils
MY_P="PyGreSQL-${PV}"
DESCRIPTION="A Python interface for the PostgreSQL database."
-SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+
LICENSE="as-is"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE="doc"
DEPEND="dev-db/postgresql-base"
RDEPEND="${DEPEND}
dev-python/egenix-mx-base"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/*.txt"
+PYTHON_MODNAME="pg.py pgdb.py"
src_install() {
distutils_src_install
- dodoc docs/*.txt
-
- if use doc ; then
+ if use doc; then
insinto /usr/share/doc/${PF}/tutorial
- doins tutorial/*
- dohtml docs/*.{html,css}
+ doins tutorial/* || die "doins failed"
+ dohtml docs/*.{html,css} || die "dohtml failed"
fi
}