summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-02 18:23:20 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-02 18:23:20 +0000
commitfc6f051f9471e6d6cabd3acead42aae5707219c4 (patch)
tree400b5230f13b52fa87298ff5a389af2e0c843be9 /dev-db
parentVersion bump thanks to neeo in bug #164832 (diff)
downloadgentoo-2-fc6f051f9471e6d6cabd3acead42aae5707219c4.tar.gz
gentoo-2-fc6f051f9471e6d6cabd3acead42aae5707219c4.tar.bz2
gentoo-2-fc6f051f9471e6d6cabd3acead42aae5707219c4.zip
The optional tcl support in sqlite must be enabled in sqlite to run tests. Just having tcl is not enough.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index dbc72e0fe35c..cd5c75ba439c 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.134 2007/02/02 18:18:19 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.135 2007/02/02 18:23:20 betelgeuse Exp $
+
+ 02 Feb 2007; Petteri Räty <betelgeuse@gentoo.org> sqlite-3.3.12.ebuild:
+ The optional tcl support in sqlite must be enabled in sqlite to run tests.
+ Just having tcl is not enough.
*sqlite-3.3.12 (02 Feb 2007)
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
index 62c2de72d5e5..ca216f1f7e35 100644
--- a/dev-db/sqlite/sqlite-3.3.12.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.1 2007/02/02 18:18:19 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.2 2007/02/02 18:23:20 betelgeuse Exp $
inherit eutils alternatives libtool
@@ -30,9 +30,11 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "Testsuite will not be run."
fi
- if ! use test; then
- eerror "The test useflag must be enabled to run tests."
- die "test use flag disabled"
+ if ! use test || ! use tcl; then
+ eerror "The test and tcl useflags must be enabled to run tests."
+ ewarn "Please note that turning on tcl installs runtime support"
+ ewarn "too."
+ die "test or tcl use flag disabled"
fi
fi