summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 09:59:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 09:59:57 +0000
commitfd9032429dba71eeb92ce2b8e3f1a4f3ee4c21b4 (patch)
treed36f0a9bd3de961f9bf7fb7df681ed3ad3c1cc1c /dev-db
parentUse bash 3.2 features. (diff)
downloadgentoo-2-fd9032429dba71eeb92ce2b8e3f1a4f3ee4c21b4.tar.gz
gentoo-2-fd9032429dba71eeb92ce2b8e3f1a4f3ee4c21b4.tar.bz2
gentoo-2-fd9032429dba71eeb92ce2b8e3f1a4f3ee4c21b4.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libdrizzle/ChangeLog10
-rw-r--r--dev-db/libdrizzle/libdrizzle-0.7.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-db/libdrizzle/ChangeLog b/dev-db/libdrizzle/ChangeLog
index 4390a8995217..abd0ae28a206 100644
--- a/dev-db/libdrizzle/ChangeLog
+++ b/dev-db/libdrizzle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdrizzle
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/ChangeLog,v 1.2 2009/12/23 18:19:22 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/ChangeLog,v 1.3 2010/01/13 09:59:57 flameeyes Exp $
+
+*libdrizzle-0.7 (13 Jan 2010)
+
+ 13 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libdrizzle-0.7.ebuild:
+ Version bump.
23 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
libdrizzle-0.6.ebuild:
diff --git a/dev-db/libdrizzle/libdrizzle-0.7.ebuild b/dev-db/libdrizzle/libdrizzle-0.7.ebuild
new file mode 100644
index 000000000000..d51c0aa838e3
--- /dev/null
+++ b/dev-db/libdrizzle/libdrizzle-0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/libdrizzle-0.7.ebuild,v 1.1 2010/01/13 09:59:57 flameeyes Exp $
+
+EAPI=2
+
+DESCRIPTION="a C client and protocol library for the Drizzle project"
+HOMEPAGE="http://launchpad.net/libdrizzle"
+SRC_URI="http://launchpad.net/libdrizzle/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug tcmalloc +sqlite static-libs"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Don't ever use --enable-assert since configure.ac is broken, and
+ # only does --disable-assert correctly.
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+
+ # Right now disabling asserts break the code, so never disable
+ # them as it is.
+ #else
+ # myconf="${myconf} --disable-assert"
+ fi
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ $(use_enable tcmalloc) \
+ $(use_enable libsqlite3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS PROTOCOL README || die
+
+ find "${D}" -name '*.la' -delete || die
+}