summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-06-28 00:59:23 +0000
committerPeter Johanson <latexer@gentoo.org>2004-06-28 00:59:23 +0000
commit8983c6f90754b3a9a4e8b22e70810f85dfc8858c (patch)
tree82a9e3c6703a66ed688d0f93cb33c7ffad0ee1e9 /dev-dotnet/mono
parentAdded ~sparc, ~mips (Manifest recommit) (diff)
downloadgentoo-2-8983c6f90754b3a9a4e8b22e70810f85dfc8858c.tar.gz
gentoo-2-8983c6f90754b3a9a4e8b22e70810f85dfc8858c.tar.bz2
gentoo-2-8983c6f90754b3a9a4e8b22e70810f85dfc8858c.zip
Release candidate goodness.
Diffstat (limited to 'dev-dotnet/mono')
-rw-r--r--dev-dotnet/mono/ChangeLog9
-rw-r--r--dev-dotnet/mono/Manifest3
-rw-r--r--dev-dotnet/mono/files/digest-mono-0.971
-rw-r--r--dev-dotnet/mono/mono-0.97.ebuild68
4 files changed, 79 insertions, 2 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index f3beb9b4023b..710ba491f024 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-dotnet/mono
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.20 2004/06/24 22:04:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.21 2004/06/28 00:58:34 latexer Exp $
+
+*mono-0.97 (27 Jun 2004)
+
+ 27 Jun 2004; Peter Johanson <latexer@gentoo.org> +mono-0.97.ebuild:
+ Release candidate goodness.
*mono-0.96 (16 Jun 2004)
- 16 Jun 2004; Peter Johanson,,, <peter@gentoo.org> mono-0.96.ebuild:
+ 16 Jun 2004; Peter Johanson, <latexer@gentoo.org> mono-0.96.ebuild:
Beta3 loves you.
02 Jun 2004; Aron Griffis <agriffis@gentoo.org> mono-0.31.ebuild,
diff --git a/dev-dotnet/mono/Manifest b/dev-dotnet/mono/Manifest
index 9e960aac2ccc..2b4741da0093 100644
--- a/dev-dotnet/mono/Manifest
+++ b/dev-dotnet/mono/Manifest
@@ -4,6 +4,8 @@ MD5 5d70aa2dc0b35bbc8d67989b9da20c8c mono-0.91.ebuild 1718
MD5 fff4d6940949f3280dcb8556749b6278 mono-0.30.1.ebuild 2451
MD5 bda2e6b82684286bc13346b7851e0473 mono-0.28.ebuild 2151
MD5 67131dd9bf95d27be0abb143fd60199a mono-0.95.ebuild 1606
+MD5 dfeac1a78d4f90b29c930fd06d680cb2 .#Manifest.1.32 1209
+MD5 3f057b764b9ad0300718f1743ecf89b3 mono-0.97.ebuild 1603
MD5 4854360d1955592fb8e93f7bf4efa93d mono-0.31.ebuild 2603
MD5 d7bf41448695033862db9bb4cc7c3d97 ChangeLog 7488
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
@@ -16,3 +18,4 @@ MD5 e7d95f62bf18430aa812b1a501c2e485 files/digest-mono-0.31 124
MD5 0145cec2f8b351f3a72669bd6f7e4e0e files/digest-mono-0.91 63
MD5 274bce1afaca6fcf8751ccea8d3d77c7 files/digest-mono-0.95 63
MD5 7aace03d500c5c79171c98bfd0ed7b7e files/digest-mono-0.96 63
+MD5 d939fa9402e075070bcaa4f397ae18d4 files/digest-mono-0.97 63
diff --git a/dev-dotnet/mono/files/digest-mono-0.97 b/dev-dotnet/mono/files/digest-mono-0.97
new file mode 100644
index 000000000000..95ed6321e453
--- /dev/null
+++ b/dev-dotnet/mono/files/digest-mono-0.97
@@ -0,0 +1 @@
+MD5 5a9766494c7efd2a352eec68b188ec49 mono-0.97.tar.gz 18210368
diff --git a/dev-dotnet/mono/mono-0.97.ebuild b/dev-dotnet/mono/mono-0.97.ebuild
new file mode 100644
index 000000000000..74c92abd2246
--- /dev/null
+++ b/dev-dotnet/mono/mono-0.97.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.97.ebuild,v 1.1 2004/06/28 00:58:34 latexer Exp $
+
+inherit eutils mono flag-o-matic
+
+strip-flags
+
+IUSE="nptl"
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+SRC_URI="http://www.go-mono.com/archive/rc/${P}.tar.gz"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="GPL-2 | LGPL-2 | X11"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-2.0
+ >=dev-libs/icu-2.6.1
+ !dev-dotnet/pnet
+ ppc? ( >=sys-devel/gcc-3.2.3-r4 )
+ ppc? ( >=sys-libs/glibc-2.3.3_pre20040420 )"
+
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_compile() {
+ local myconf=""
+ if use nptl && have_NPTL
+ then
+ myconf="${myconf} --with-nptl=yes"
+ else
+ myconf="${myconf} --with-nptl=no"
+ fi
+
+ econf ${myconf} || die
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "MONO compilation failure"
+}
+
+src_install () {
+ cd ${S}
+ make DESTDIR=${D} install || die
+ # einstall || die
+
+ dodoc AUTHORS ChangeLog COPYING.LIB NEWS README
+ docinto docs
+ dodoc docs/*
+
+ # install mono's logo
+ insopts -m0644
+ insinto /usr/share/pixmaps/mono
+ doins MonoIcon.png ScalableMonoIcon.svg
+
+ # init script
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dotnet.init dotnet
+ insinto /etc/conf.d ; newins ${FILESDIR}/dotnet.conf dotnet
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you want to avoid typing '<runtime> program.exe'"
+ einfo "you can configure your runtime in /etc/conf.d/dotnet"
+ einfo "Use /etc/init.d/dotnet to register your runtime"
+ echo
+}