summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-24 19:22:57 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-24 19:22:57 +0000
commit751a1efec518e3da5c3336d7214039e44901c538 (patch)
tree11683eceef7a1ce24b53dd23498e5e1c052231b8 /dev-dotnet/monouml/monouml-0.1.ebuild
parentx86 stable wrt #178027 (diff)
downloadgentoo-2-751a1efec518e3da5c3336d7214039e44901c538.tar.gz
gentoo-2-751a1efec518e3da5c3336d7214039e44901c538.tar.bz2
gentoo-2-751a1efec518e3da5c3336d7214039e44901c538.zip
dev-dotnet/monouml: initial version (fixing bug #104444)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-dotnet/monouml/monouml-0.1.ebuild')
-rw-r--r--dev-dotnet/monouml/monouml-0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-dotnet/monouml/monouml-0.1.ebuild b/dev-dotnet/monouml/monouml-0.1.ebuild
new file mode 100644
index 000000000000..a15ae3243901
--- /dev/null
+++ b/dev-dotnet/monouml/monouml-0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monouml/monouml-0.1.ebuild,v 1.1 2007/06/24 19:22:57 jurek Exp $
+
+inherit mono eutils
+
+MY_PV=20050529
+MY_P=${P}-${MY_PV}
+EC_P=expertcoder-bin-20050503
+
+DESCRIPTION="CASE tool based on Mono Framework"
+HOMEPAGE="http://www.monouml.org"
+SRC_URI="http://forge.novell.com/modules/xfcontent/private.php/${PN}/MonoUML/${MY_P}.tar.gz
+ mirror://sourceforge/expertcoder/${EC_P}.zip"
+
+LICENSE="GPL-2"
+IUSE=""
+DEPEND=">=dev-lang/mono-1.1.4
+ >=dev-dotnet/gtk-sharp-1.9.2
+ app-arch/unzip"
+
+KEYWORDS="~x86"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ cp ${WORKDIR}/${EC_P}/*.dll ${WORKDIR}/${P}/bin/ || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Workaround for messed up paths
+ dodir /usr/$(get_libdir)
+ mv ${D}/usr/monouml ${D}/usr/$(get_libdir)/
+ sed -i -e "s#/usr/${PN}#/usr/$(get_libdir)/${PN}#g" ${D}/usr/bin/monouml
+
+ dodoc ChangeLog README AUTHORS
+}