summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-13 10:34:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-13 10:34:00 +0000
commitdad5eb146d188626bd690aea781fe0e2e1f87ecf (patch)
tree8c5616a6602c1b95ed2b9134c24fe69c25bd3b95 /dev-embedded/libftdi
parentVersion bump. (diff)
downloadgentoo-2-dad5eb146d188626bd690aea781fe0e2e1f87ecf.tar.gz
gentoo-2-dad5eb146d188626bd690aea781fe0e2e1f87ecf.tar.bz2
gentoo-2-dad5eb146d188626bd690aea781fe0e2e1f87ecf.zip
Version bump.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/ChangeLog7
-rw-r--r--dev-embedded/libftdi/libftdi-0.14.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index cdddfcdc88aa..f3e643bba716 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/libftdi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.31 2008/07/01 15:35:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.32 2008/10/13 10:34:00 vapier Exp $
+
+*libftdi-0.14 (13 Oct 2008)
+
+ 13 Oct 2008; Mike Frysinger <vapier@gentoo.org> +libftdi-0.14.ebuild:
+ Version bump.
*libftdi-0.13 (01 Jul 2008)
diff --git a/dev-embedded/libftdi/libftdi-0.14.ebuild b/dev-embedded/libftdi/libftdi-0.14.ebuild
new file mode 100644
index 000000000000..96bdb461dc50
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.14.ebuild,v 1.1 2008/10/13 10:34:00 vapier Exp $
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/opensource/ftdi/"
+SRC_URI="http://www.intra2net.com/opensource/ftdi/TGZ/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libusb-0.1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+
+ use doc || export ac_cv_path_DOXYGEN=true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}