summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-23 12:27:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-23 12:27:02 +0000
commit92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b (patch)
tree1573c450a4f23d5acfc12a1e4c84cc74c91df0b4 /dev-games/KXL/KXL-1.1.7-r2.ebuild
parentFix some ewarn calls for the upcoming net-dns/bind-9.4.3_p5-r1 bump. (diff)
downloadgentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.tar.gz
gentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.tar.bz2
gentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.zip
Respect LDFLAGS (for all the ebuild that use it). Bug #337869
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-games/KXL/KXL-1.1.7-r2.ebuild')
-rw-r--r--dev-games/KXL/KXL-1.1.7-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-games/KXL/KXL-1.1.7-r2.ebuild b/dev-games/KXL/KXL-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..b8ddc0638482
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/KXL-1.1.7-r2.ebuild,v 1.1 2010/09/23 12:27:02 tupone Exp $
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}