summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-12 23:38:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-12 23:38:03 +0000
commit842f1cf8d08856453b370dd8c1591772a077fe9e (patch)
tree93236917e88d10365da88bc35dc006ae996e64fc /dev-games/clanlib
parentversion bump (diff)
downloadgentoo-2-842f1cf8d08856453b370dd8c1591772a077fe9e.tar.gz
gentoo-2-842f1cf8d08856453b370dd8c1591772a077fe9e.tar.bz2
gentoo-2-842f1cf8d08856453b370dd8c1591772a077fe9e.zip
Patch for gcc-4.2
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog8
-rw-r--r--dev-games/clanlib/clanlib-0.8.0.ebuild10
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.0-gcc42.patch11
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index eb7407e74c74..3e2a5ca4fc75 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.37 2006/09/23 12:19:54 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.38 2007/06/12 23:38:03 nyhm Exp $
+
+ 12 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/clanlib-0.8.0-gcc42.patch, clanlib-0.8.0.ebuild:
+ Patch for gcc-4.2
*clanlib-0.8.0 (23 Sep 2006)
diff --git a/dev-games/clanlib/clanlib-0.8.0.ebuild b/dev-games/clanlib/clanlib-0.8.0.ebuild
index 9c2ffdca4171..9f3f73cde9d2 100644
--- a/dev-games/clanlib/clanlib-0.8.0.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.0.ebuild,v 1.1 2006/09/23 12:19:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.0.ebuild,v 1.2 2007/06/12 23:38:03 nyhm Exp $
inherit flag-o-matic eutils
@@ -33,6 +33,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/ClanLib-${PV}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc42.patch
+}
+
src_compile() {
#clanSound only controls mikmod/vorbis so there's
# no need to pass --{en,dis}able-clanSound ...
diff --git a/dev-games/clanlib/files/clanlib-0.8.0-gcc42.patch b/dev-games/clanlib/files/clanlib-0.8.0-gcc42.patch
new file mode 100644
index 000000000000..bd5274ab4098
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.0-gcc42.patch
@@ -0,0 +1,11 @@
+--- Sources/API/GL/opengl_wrap.h
++++ Sources/API/GL/opengl_wrap.h
+@@ -2530,7 +2530,7 @@
+ typedef CLuint (CL_GLFUNC *ptr_glCreateShaderObjectARB )(CLenum shaderType);
+ typedef CLvoid (CL_GLFUNC *ptr_glShaderSourceARB)(CLuint shaderObj, CLsizei count, const CLchar* *string, const CLint *length);
+ typedef CLvoid (CL_GLFUNC *ptr_glCompileShaderARB)(CLuint shaderObj);
+- typedef CLuint (CL_GLFUNC *ptr_glCreateProgramObjectARB)(CLvoid);
++ typedef CLuint (CL_GLFUNC *ptr_glCreateProgramObjectARB)(void);
+ typedef CLvoid (CL_GLFUNC *ptr_glAttachObjectARB)(CLuint containerObj, CLuint attachedObj);
+ typedef CLvoid (CL_GLFUNC *ptr_glLinkProgramARB)(CLuint programObj);
+ typedef CLvoid (CL_GLFUNC *ptr_glUseProgramObjectARB)(CLuint programObj);