summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-29 22:01:46 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-29 22:01:46 +0000
commitcf400193e12ce26a76bceb56a8c085402ae1abc8 (patch)
tree93cd285921e62e9e33c6da32d4e085e1186879d6 /dev-games/clanlib
parentAdd missing dependency on virtual/glu (diff)
downloadgentoo-2-cf400193e12ce26a76bceb56a8c085402ae1abc8.tar.gz
gentoo-2-cf400193e12ce26a76bceb56a8c085402ae1abc8.tar.bz2
gentoo-2-cf400193e12ce26a76bceb56a8c085402ae1abc8.zip
Fix building with gcc 4.7, wrt bug #448428
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog7
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild3
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch10
3 files changed, 18 insertions, 2 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 60fedb4fed91..4348bd3081b6 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.61 2012/12/29 21:58:59 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.62 2012/12/29 22:01:44 pinkbyte Exp $
+
+ 29 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> clanlib-0.8.1.ebuild,
+ +files/clanlib-0.8.1-gcc47.patch:
+ Fix building with gcc 4.7, wrt bug #448428. Thanks to Diego Elio Pettenò for
+ discovering this issue
29 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> clanlib-0.8.1.ebuild:
Add missing dependency on virtual/glu
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
index 7ce2a42c64a6..13522871f12c 100644
--- a/dev-games/clanlib/clanlib-0.8.1.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.1.ebuild,v 1.11 2012/12/29 21:58:59 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.1.ebuild,v 1.12 2012/12/29 22:01:44 pinkbyte Exp $
EAPI=2
inherit flag-o-matic eutils
@@ -40,6 +40,7 @@ src_prepare() {
"${FILESDIR}"/${P}-ndebug.patch \
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-libpng15.patch
}
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
new file mode 100644
index 000000000000..19ebab6fd07d
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
@@ -0,0 +1,10 @@
+--- ./Sources/Core/IOData/Generic/inputsource_file.cpp.orig 2012-12-30 01:49:01.698950614 +0400
++++ ./Sources/Core/IOData/Generic/inputsource_file.cpp 2012-12-30 01:49:27.714977456 +0400
+@@ -32,6 +32,7 @@
+ #ifdef WIN32
+ #include <direct.h>
+ #endif
++#include <unistd.h>
+ #include <cstring>
+ #include <API/Core/IOData/inputsource_file.h>
+