summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-02-06 13:56:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-02-06 13:56:37 +0000
commitdde0b5c459de07f06abeea223a9fe5612bdc0ab1 (patch)
treec1ca476d8054058b2336f04b86512a5b6f464f63 /dev-games/clanlib
parentFixed FEATURES="test", which apparently has not been working for a while. (diff)
downloadgentoo-2-dde0b5c459de07f06abeea223a9fe5612bdc0ab1.tar.gz
gentoo-2-dde0b5c459de07f06abeea223a9fe5612bdc0ab1.tar.bz2
gentoo-2-dde0b5c459de07f06abeea223a9fe5612bdc0ab1.zip
Version bump to 2.4.3 Bug #288218
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog10
-rw-r--r--dev-games/clanlib/clanlib-2.3.4.ebuild86
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.4-autotools.patch51
3 files changed, 145 insertions, 2 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index fb88b0cee4ef..e9a0872c7c89 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.49 2011/09/15 02:31:01 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.50 2012/02/06 13:56:37 tupone Exp $
+
+*clanlib-2.3.4 (06 Feb 2012)
+
+ 06 Feb 2012; Tupone Alfredo <tupone@gentoo.org> +clanlib-2.3.4.ebuild,
+ +files/clanlib-2.3.4-autotools.patch:
+ Version bump to 2.4.3 Bug #288218 by proDOOMman
15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> clanlib-0.8.1.ebuild,
+files/clanlib-0.8.1-libpng15.patch:
diff --git a/dev-games/clanlib/clanlib-2.3.4.ebuild b/dev-games/clanlib/clanlib-2.3.4.ebuild
new file mode 100644
index 000000000000..c77c7e5761bf
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.4.ebuild,v 1.1 2012/02/06 13:56:37 tupone Exp $
+
+EAPI=2
+inherit flag-o-matic eutils autotools-utils
+
+MY_P=ClanLib-${PV}
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="doc ipv6 mikmod opengl sound sqlite sse2 static-libs vorbis X"
+
+RDEPEND="sys-libs/zlib
+ X? (
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/freetype
+ media-libs/fontconfig
+ opengl? ( virtual/opengl )
+ app-arch/bzip2
+ x11-libs/libX11
+ )
+ sqlite? ( dev-db/sqlite )
+ sound? (
+ media-libs/alsa-lib
+ mikmod? ( media-libs/libmikmod )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen dev-lang/perl )"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=(
+ CODING_STYLE
+ CREDITS
+ PATCHES
+ README
+)
+
+src_configure() {
+ myeconfargs=(
+ --disable-dependency-tracking
+ $(use_enable doc docs)
+ $(use_enable sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable sound clanSound)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ autotools-utils_src_install
+ if use doc ; then
+ emake DESTDIR="${D}" install-html || die "emake html-install failed"
+ cp -r Examples Resources "${D}"/usr/share/doc/${PF}/ \
+ || die "Copying failed"
+ fi
+}
diff --git a/dev-games/clanlib/files/clanlib-2.3.4-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.4-autotools.patch
new file mode 100644
index 000000000000..47a7b4ba1314
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.4-autotools.patch
@@ -0,0 +1,51 @@
+--- configure.ac.old 2012-02-03 14:10:59.163215573 +0100
++++ configure.ac 2012-02-03 14:12:18.003215948 +0100
+@@ -333,11 +333,9 @@
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
+- AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
+
+ dnl Optional linux/input.h
+ AC_CHECK_HEADERS(linux/input.h, linux_input=yes)
+- AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ if test "$WIN32" = "no" && test "$enable_clanDisplay" != "no"; then
+ CLANLIB_CHECK_LIB(fontconfig, [`cat $srcdir/Setup/Tests/fontconfig.cpp`], clanDisplay, [ *** Cannot find fontconfig (See http://fontconfig.org/ ) (Try libfontconfig1-dev or better) ], [-lfontconfig])
+@@ -355,6 +353,9 @@
+ fi
+ fi
+
++AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
++AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
++
+ have_xrender=no
+
+ if test "$enable_clanDisplay" != "no"; then
+@@ -507,13 +507,14 @@
+ fi
+
+ extra_LIBS_clanSound="$extra_LIBS_clanSound $sound_libs"
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+
+ fi
+
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
++
+ if test "$enable_clanSound" != "no"; then
+ enable_clanSound=yes
+ echo "Checking for clanMikmod stuff"
+--- Documentation/Reference/Makefile.am.old 2012-02-06 16:00:50.034478851 +0100
++++ Documentation/Reference/Makefile.am 2012-02-06 16:01:01.524478906 +0100
+@@ -10,7 +10,7 @@
+ mkdir doxyoutput;
+ mkdir reftest
+ doxygen ./clanlib.doxygen
+- make -C ../Utilities/ReferenceDocs
++ $(MAKE) -C ../Utilities/ReferenceDocs
+ ../Utilities/ReferenceDocs/ReferenceDocs
+
+ install-html: