summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-31 08:50:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-31 08:50:46 +0000
commitee81f34d260ff53f7801e1bb10245da63ac14d17 (patch)
tree2c5a5352239497a675812ee4697db3eb83a1eeea /dev-games/crystalspace
parentAdding USE flags for crystalspace-1.0 (diff)
downloadgentoo-2-ee81f34d260ff53f7801e1bb10245da63ac14d17.tar.gz
gentoo-2-ee81f34d260ff53f7801e1bb10245da63ac14d17.tar.bz2
gentoo-2-ee81f34d260ff53f7801e1bb10245da63ac14d17.zip
Version bump to 1.0 . Bug #155788
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-games/crystalspace')
-rw-r--r--dev-games/crystalspace/ChangeLog9
-rw-r--r--dev-games/crystalspace/crystalspace-1.0.ebuild80
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-0.98.42
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-0.99_pre200508232
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-1.03
5 files changed, 94 insertions, 2 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index 224c235bd990..68f0ca264e62 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/crystalspace
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.18 2006/08/14 09:49:23 genstef Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.19 2007/01/31 08:50:46 tupone Exp $
+
+*crystalspace-1.0 (31 Jan 2007)
+
+ 31 Jan 2007; <tupone@gentoo.org> +crystalspace-1.0.ebuild:
+ Version bump to 1.0 . Bug #155788 by loux thefuture
14 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
crystalspace-0.98.4.ebuild:
diff --git a/dev-games/crystalspace/crystalspace-1.0.ebuild b/dev-games/crystalspace/crystalspace-1.0.ebuild
new file mode 100644
index 000000000000..bb220e7cdcfe
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-1.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.ebuild,v 1.1 2007/01/31 08:50:46 tupone Exp $
+
+MY_P=${PN}-src-${PV}
+
+DESCRIPTION="Portable 3D Game Development Kit written in C++"
+HOMEPAGE="http://crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3ds alsa cal3d cegui cg java jpeg lcms mng ode perl png python sdl
+truetype vorbis wxwindows"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ java? ( virtual/jre )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ ode? ( dev-games/ode )
+ cal3d? ( =media-libs/cal3d-0.11* )
+ jpeg? ( media-libs/jpeg
+ lcms? ( media-libs/lcms ) )
+ sdl? ( media-libs/libsdl )
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )
+ truetype? ( >=media-libs/freetype-2.1 )
+ alsa? ( media-libs/alsa-lib )
+ mng? ( media-libs/libmng )
+ png? ( media-libs/libpng )
+ wxwindows? ( x11-libs/pango
+ x11-libs/wxGTK )
+ x11-libs/libXaw
+ x11-libs/libXxf86vm"
+
+DEPEND="${RDEPEND}
+ 3ds? ( media-libs/lib3ds )
+ java? ( dev-java/ant-core
+ virtual/jdk )
+ dev-util/jam
+ dev-lang/swig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --enable-cpu-specific-optimizations=no \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with java) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with lcms) \
+ $(use_with mng) \
+ $(use_with vorbis) \
+ $(use_with 3ds) \
+ $(use_with ode) \
+ $(use_with truetype freetype2) \
+ $(use_with cal3d) \
+ $(use_with sdl) \
+ $(use_with wxwindows wx) \
+ $(use_with cegui CEGUI) \
+ $(use_with cg Cg) \
+ $(use_with alsa asound)
+ #remove unwanted CFLAGS added by ./configure
+ sed -i -e '/COMPILER\.CFLAGS\.optimize/d' \
+ Jamconfig
+ jam || die "compile failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ # Fill cache directory for the examples
+ for dir in castle flarge isomap parallaxtest partsys r3dtest stenciltest \
+ terrain terrainf;
+ do
+ cslight -video=null ${D}/usr/share/${PN}/data/maps/$dir;
+ done
+ dodoc README
+}
diff --git a/dev-games/crystalspace/files/digest-crystalspace-0.98.4 b/dev-games/crystalspace/files/digest-crystalspace-0.98.4
index b66414156350..9c96c71ccbac 100644
--- a/dev-games/crystalspace/files/digest-crystalspace-0.98.4
+++ b/dev-games/crystalspace/files/digest-crystalspace-0.98.4
@@ -1 +1,3 @@
MD5 e11c3ef1d7d519a4188f52a8fa83a319 cs98_004.tar.bz2 20709835
+RMD160 5f23c49c6054f3c94ef15b542ef3b30d7f86c0dd cs98_004.tar.bz2 20709835
+SHA256 f95fda79d33627e1a8ecbdba8ca823018490d57d9f1a1c19682d9c00c0effc01 cs98_004.tar.bz2 20709835
diff --git a/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823 b/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823
index b91854078458..28f5b394e1b8 100644
--- a/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823
+++ b/dev-games/crystalspace/files/digest-crystalspace-0.99_pre20050823
@@ -1 +1,3 @@
MD5 9e64e862ea334dd3391221f30236a02a crystalspace-0.99_pre20050823.tar.bz2 24423240
+RMD160 554dc478ce6d2598abfac56ffd0df03c3f8b03d7 crystalspace-0.99_pre20050823.tar.bz2 24423240
+SHA256 8f9b3d4ee36dda5f5ae9bb8b08eeda1db1e005fc22a5969323c65b0dd1f0bee1 crystalspace-0.99_pre20050823.tar.bz2 24423240
diff --git a/dev-games/crystalspace/files/digest-crystalspace-1.0 b/dev-games/crystalspace/files/digest-crystalspace-1.0
new file mode 100644
index 000000000000..703bdcecf114
--- /dev/null
+++ b/dev-games/crystalspace/files/digest-crystalspace-1.0
@@ -0,0 +1,3 @@
+MD5 3a7c958f43253326c5ae377793151631 crystalspace-src-1.0.tar.bz2 36567521
+RMD160 f1328a1d707b219ad09f8e76c655e4d00f4dcbae crystalspace-src-1.0.tar.bz2 36567521
+SHA256 30f9f2936cfceae1431ffa50512aaf94abb039ebffa468c757027f76ac9bc9c5 crystalspace-src-1.0.tar.bz2 36567521