summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-10 05:35:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-10 05:35:37 +0000
commit4d358e3b9a9e2d972a773833ea0bd035a8efa2db (patch)
tree6fb4c14f7774622e59f9c2c86b36390ad87d6284 /dev-games/guichan
parentMark 0.2.6 stable on alpha (diff)
downloadgentoo-2-4d358e3b9a9e2d972a773833ea0bd035a8efa2db.tar.gz
gentoo-2-4d358e3b9a9e2d972a773833ea0bd035a8efa2db.tar.bz2
gentoo-2-4d358e3b9a9e2d972a773833ea0bd035a8efa2db.zip
Remove -Werror hardcode from CXXFLAGS #105340 by Anatoly Kamchatnov.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-games/guichan')
-rw-r--r--dev-games/guichan/ChangeLog5
-rw-r--r--dev-games/guichan/guichan-0.4.0.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index 1e25b905da9d..593cda0698be 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/guichan
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.3 2005/07/06 07:29:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.4 2005/09/10 05:35:37 vapier Exp $
+
+ 10 Sep 2005; Mike Frysinger <vapier@gentoo.org> guichan-0.4.0.ebuild:
+ Remove -Werror hardcode from CXXFLAGS #105340 by Anatoly Kamchatnov.
06 Jul 2005; David Holm <dholm@gentoo.org> guichan-0.4.0.ebuild:
Added to ~ppc.
diff --git a/dev-games/guichan/guichan-0.4.0.ebuild b/dev-games/guichan/guichan-0.4.0.ebuild
index 83854fe05b0b..6c7b6d357185 100644
--- a/dev-games/guichan/guichan-0.4.0.ebuild
+++ b/dev-games/guichan/guichan-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.4.0.ebuild,v 1.2 2005/07/06 07:29:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.4.0.ebuild,v 1.3 2005/09/10 05:35:37 vapier Exp $
DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
HOMEPAGE="http://guichan.sourceforge.net/"
@@ -15,6 +15,14 @@ DEPEND="opengl? ( virtual/opengl )
sdl? ( media-libs/libsdl media-libs/sdl-image )
allegro? ( media-libs/allegro )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^CXXFLAGS=/s:-Werror::' \
+ configure || die "sed configure failed"
+}
+
src_compile() {
econf \
$(use_enable allegro) \
@@ -24,6 +32,7 @@ src_compile() {
|| die "Configuration failed"
emake || die "Build failed"
}
+
src_install() {
make install DESTDIR="${D}" || die "Installation failed"
dodoc AUTHORS ChangeLog NEWS README TODO