summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-20 17:11:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-20 17:11:16 +0000
commit7f6b8c50b00f21690bc5e1702004b9d0d0738a42 (patch)
treedde2f9beea6520583552e0ac9f5da7eebdd9652b /dev-games/ogre
parentBug #215160, again. (diff)
downloadgentoo-2-7f6b8c50b00f21690bc5e1702004b9d0d0738a42.tar.gz
gentoo-2-7f6b8c50b00f21690bc5e1702004b9d0d0738a42.tar.bz2
gentoo-2-7f6b8c50b00f21690bc5e1702004b9d0d0738a42.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-games/ogre')
-rw-r--r--dev-games/ogre/ChangeLog9
-rw-r--r--dev-games/ogre/files/ogre-1.4.9-as-needed.patch11
-rw-r--r--dev-games/ogre/files/ogre-1.4.9-cegui.patch19
-rw-r--r--dev-games/ogre/ogre-1.4.9.ebuild90
4 files changed, 128 insertions, 1 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index 7c1414cadd49..0565da07ded0 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.50 2008/06/02 01:59:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.51 2008/06/20 17:11:15 mr_bones_ Exp $
+
+*ogre-1.4.9 (20 Jun 2008)
+
+ 20 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ogre-1.4.9-as-needed.patch, +files/ogre-1.4.9-cegui.patch,
+ +ogre-1.4.9.ebuild:
+ version bump
02 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org> ogre-1.4.8.ebuild:
strip-flags for bugs like #186734
diff --git a/dev-games/ogre/files/ogre-1.4.9-as-needed.patch b/dev-games/ogre/files/ogre-1.4.9-as-needed.patch
new file mode 100644
index 000000000000..ce218097f770
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.4.9-as-needed.patch
@@ -0,0 +1,11 @@
+--- acinclude.m4.orig 2008-04-09 17:49:30.848987000 +0100
++++ acinclude.m4 2008-04-09 17:53:25.652068359 +0100
+@@ -340,7 +340,7 @@
+ * --disable-cg to this configure script but this is highly *
+ * discouraged as this breaks many of the examples. *
+ ****************************************************************])
+- )
++ ,-Xlinker --no-as-needed)
+ fi
+
+ AM_CONDITIONAL(BUILD_CGPLUGIN, test x$build_cg = xyes)
diff --git a/dev-games/ogre/files/ogre-1.4.9-cegui.patch b/dev-games/ogre/files/ogre-1.4.9-cegui.patch
new file mode 100644
index 000000000000..c089164af219
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.4.9-cegui.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4
++++ acinclude.m4
+@@ -411,6 +411,8 @@
+ ])
+
+ AC_DEFUN([OGRE_CHECK_CEGUI], [
++ AC_ARG_ENABLE(cegui)
++ if test x$enable_cegui != xno; then
+ PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.5.0,
+ [build_cegui_sample=true], [build_cegui_sample=false])
+ if test x$build_cegui_sample = xtrue; then
+@@ -426,6 +428,7 @@
+ else
+ AC_MSG_RESULT([CEGUI not available, Gui and FacialAnimation samples will not be built])
+ fi
++ fi
+ AM_CONDITIONAL([HAVE_CEGUI], [test x$build_cegui_sample = xtrue])
+ ])
+
diff --git a/dev-games/ogre/ogre-1.4.9.ebuild b/dev-games/ogre/ogre-1.4.9.ebuild
new file mode 100644
index 000000000000..339f6a23bbbf
--- /dev/null
+++ b/dev-games/ogre/ogre-1.4.9.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.9.ebuild,v 1.1 2008/06/20 17:11:15 mr_bones_ Exp $
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Object-oriented Graphics Rendering Engine"
+HOMEPAGE="http://www.ogre3d.org/"
+SRC_URI="mirror://sourceforge/ogre/ogre-v${PV//./-}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc cegui cg devil double-precision examples gtk openexr threads"
+RESTRICT="test" #139905
+
+RDEPEND="dev-libs/zziplib
+ >=media-libs/freetype-2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXrandr
+ x11-libs/libX11
+ cegui? ( >=dev-games/cegui-0.5 )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ devil? ( media-libs/devil )
+ gtk? ( >=x11-libs/gtk+-2 )
+ openexr? ( media-libs/openexr )
+ threads? ( dev-libs/boost )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if use threads && ! built_with_use --missing true dev-libs/boost threads
+ then
+ die "Please emerge dev-libs/boost with USE=threads"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+ if use examples ; then
+ cp -r Samples install-examples || die
+ find install-examples \
+ '(' -name 'Makefile*' -o -name obj -o \
+ -name bin -o -name '*.cbp' -o -name '*.vcproj*' ')' \
+ -print0 | xargs -0 rm -rf
+ fi
+ sed -i -e '/CPPUNIT/d' configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-*.patch
+ eautoreconf
+}
+
+src_compile() {
+ strip-flags
+ econf \
+ --disable-dependency-tracking \
+ --disable-freeimage \
+ --disable-ogre-demos \
+ --enable-static \
+ --with-platform=GLX \
+ --with-gui=$(usev gtk || echo Xt) \
+ $(use_enable cegui) \
+ $(use_enable cg) \
+ $(use_enable devil) \
+ $(use_enable double-precision double) \
+ $(use_enable openexr) \
+ $(use_enable threads threading) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r Docs/* || die "doins Docs failed"
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/Samples
+ doins -r install-examples/* || die "doins Samples failed"
+ fi
+ dodoc AUTHORS BUGS LINUX.DEV README
+}