summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-14 03:34:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-14 03:34:18 +0000
commit96214e28f27ff950082a765f6d53f833b7070b99 (patch)
treedeeb640000f8569e200b425060250df24709ac4d /dev-games/vamos
parentAdd ZFS detection by Richard Yao (bug #419157). (diff)
downloadgentoo-2-96214e28f27ff950082a765f6d53f833b7070b99.tar.gz
gentoo-2-96214e28f27ff950082a765f6d53f833b7070b99.tar.bz2
gentoo-2-96214e28f27ff950082a765f6d53f833b7070b99.zip
version bump (bug #443040)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games/vamos')
-rw-r--r--dev-games/vamos/ChangeLog8
-rw-r--r--dev-games/vamos/files/vamos-0.7.0-as-needed.patch12
-rw-r--r--dev-games/vamos/vamos-0.7.0.ebuild44
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-games/vamos/ChangeLog b/dev-games/vamos/ChangeLog
index 78b4c33de6ec..277f08abcc63 100644
--- a/dev-games/vamos/ChangeLog
+++ b/dev-games/vamos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/vamos
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/ChangeLog,v 1.17 2012/05/03 06:35:31 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/ChangeLog,v 1.18 2012/11/14 03:34:17 mr_bones_ Exp $
+
+*vamos-0.7.0 (14 Nov 2012)
+
+ 14 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vamos-0.7.0-as-needed.patch, +vamos-0.7.0.ebuild:
+ version bump (bug #443040)
03 May 2012; Jeff Horelick <jdhore@gentoo.org> vamos-0.6.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-games/vamos/files/vamos-0.7.0-as-needed.patch b/dev-games/vamos/files/vamos-0.7.0-as-needed.patch
new file mode 100644
index 000000000000..002248fe89c4
--- /dev/null
+++ b/dev-games/vamos/files/vamos-0.7.0-as-needed.patch
@@ -0,0 +1,12 @@
+diff -ru vamos-0.7.0.orig/media/Makefile.in vamos-0.7.0/media/Makefile.in
+--- vamos-0.7.0.orig/media/Makefile.in 2012-01-14 20:09:15.000000000 -0500
++++ vamos-0.7.0/media/Makefile.in 2012-11-13 22:05:07.029327654 -0500
+@@ -71,7 +71,7 @@
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+ am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgincludedir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libvamos_media_la_LIBADD =
++libvamos_media_la_LIBADD = ../geometry/libvamos-geometry.la
+ am_libvamos_media_la_OBJECTS = Ac3d.lo Sample.lo Texture_Image.lo \
+ XML_Parser.lo
+ libvamos_media_la_OBJECTS = $(am_libvamos_media_la_OBJECTS)
diff --git a/dev-games/vamos/vamos-0.7.0.ebuild b/dev-games/vamos/vamos-0.7.0.ebuild
new file mode 100644
index 000000000000..446fbef2693b
--- /dev/null
+++ b/dev-games/vamos/vamos-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/vamos-0.7.0.ebuild,v 1.1 2012/11/14 03:34:17 mr_bones_ Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="an automotive simulation framework"
+HOMEPAGE="http://vamos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video]
+ media-libs/openal
+ media-libs/freealut"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-unit-tests \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dobin caelum/.libs/caelum
+ newdoc caelum/README README.caelum
+ dodoc AUTHORS ChangeLog README TODO
+ prune_libtool_files
+}