summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-03 22:33:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-03 22:33:34 +0000
commit6de887f590c99028c0bf3d5284ab96f0b2b35cae (patch)
treee4029635de96ffd65e50833a9cddbf15d5cb39ef /dev-games/wfmath/wfmath-0.3.7.ebuild
parentUpdate some components, ebuild cleanup (diff)
downloadgentoo-2-6de887f590c99028c0bf3d5284ab96f0b2b35cae.tar.gz
gentoo-2-6de887f590c99028c0bf3d5284ab96f0b2b35cae.tar.bz2
gentoo-2-6de887f590c99028c0bf3d5284ab96f0b2b35cae.zip
Version bump to 0.3.7
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-games/wfmath/wfmath-0.3.7.ebuild')
-rw-r--r--dev-games/wfmath/wfmath-0.3.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-games/wfmath/wfmath-0.3.7.ebuild b/dev-games/wfmath/wfmath-0.3.7.ebuild
new file mode 100644
index 000000000000..272a9026c01e
--- /dev/null
+++ b/dev-games/wfmath/wfmath-0.3.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.7.ebuild,v 1.1 2007/12/03 22:33:34 tupone Exp $
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ media-libs/atlas-c++"
+
+src_compile() {
+ econf || die
+ emake || die "emake failed"
+ if use doc; then
+ cd doc && emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}