summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-25 15:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-25 15:36:47 +0000
commit17cc4b27854326b5756709738a1345ca13cfbb98 (patch)
tree538756efedf7e3090febff09c05eb9d0775b7570 /dev-games
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-17cc4b27854326b5756709738a1345ca13cfbb98.tar.gz
gentoo-2-17cc4b27854326b5756709738a1345ca13cfbb98.tar.bz2
gentoo-2-17cc4b27854326b5756709738a1345ca13cfbb98.zip
Version bump to fix bugs.
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace-cvs/ChangeLog8
-rw-r--r--dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild54
-rw-r--r--dev-games/crystalspace-cvs/crystalspace-cvs-0.99.ebuild64
-rw-r--r--dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.99 (renamed from dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.97)0
4 files changed, 71 insertions, 55 deletions
diff --git a/dev-games/crystalspace-cvs/ChangeLog b/dev-games/crystalspace-cvs/ChangeLog
index 322fc23e4341..c84169164d70 100644
--- a/dev-games/crystalspace-cvs/ChangeLog
+++ b/dev-games/crystalspace-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/crystalspace-cvs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/ChangeLog,v 1.8 2004/06/30 20:01:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/ChangeLog,v 1.9 2004/12/25 15:36:47 vapier Exp $
+
+*crystalspace-cvs-0.99 (25 Dec 2004)
+
+ 25 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ -crystalspace-cvs-0.97.ebuild, +crystalspace-cvs-0.99.ebuild:
+ Version bump to fix bugs.
30 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
crystalspace-cvs-0.97.ebuild:
diff --git a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild b/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
deleted file mode 100644
index ade03578586e..000000000000
--- a/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.97.ebuild,v 1.15 2004/06/30 20:01:30 mr_bones_ Exp $
-
-inherit cvs
-ECVS_SERVER="cvs.sourceforge.net:/cvsroot/crystal"
-ECVS_MODULE="CS"
-ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
-S=${WORKDIR}/${ECVS_MODULE}
-
-DESCRIPTION="portable 3D Game Development Kit written in C++"
-HOMEPAGE="http://crystal.sourceforge.net/"
-SRC_URI=""
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="3ds truetype mikmod mng oggvorbis openal zlib"
-
-RDEPEND=">=media-libs/libpng-1.2.1
- >=media-libs/jpeg-6b
- mng? ( media-libs/libmng )
- mikmod? ( media-libs/libmikmod )
- 3ds? ( media-libs/lib3ds )
- truetype? ( >=media-libs/freetype-2.0 )
- openal? ( media-libs/openal )
- zlib? ( sys-libs/zlib )
- oggvorbis? (
- >=media-libs/libogg-1.0
- >=media-libs/libvorbis-1.0 )
- dev-games/ode
- >=dev-lang/perl-5.6.1
- !dev-games/crystalspace"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
-
-CRYSTAL_PREFIX=/opt/crystal
-
-src_compile() {
- ./configure --prefix=${CRYSTAL_PREFIX} || die
- emake -j1 all || die "emake failed"
-}
-
-src_install() {
- dodir ${CRYSTAL_PREFIX}
- make INSTALL_DIR=${D}/${CRYSTAL_PREFIX} install || die
- dodir /usr/bin
- dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
- find ${D}/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
- find ${D}/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
- chmod a+rx ${D}/${CRYSTAL_PREFIX}/{bin,lib}/*
- dodir /etc/env.d
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > ${D}/etc/env.d/90crystalspace
-}
diff --git a/dev-games/crystalspace-cvs/crystalspace-cvs-0.99.ebuild b/dev-games/crystalspace-cvs/crystalspace-cvs-0.99.ebuild
new file mode 100644
index 000000000000..d49bfb13d986
--- /dev/null
+++ b/dev-games/crystalspace-cvs/crystalspace-cvs-0.99.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-cvs/crystalspace-cvs-0.99.ebuild,v 1.1 2004/12/25 15:36:47 vapier Exp $
+
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/crystal"
+ECVS_MODULE="CS"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+inherit cvs
+
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+HOMEPAGE="http://crystal.sourceforge.net/"
+SRC_URI=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE="oggvorbis mikmod openal truetype 3ds mng"
+
+RDEPEND="sys-libs/zlib
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ truetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ oggvorbis? (
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ dev-games/ode
+ >=dev-lang/perl-5.6.1"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51
+ dev-util/jam
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${ECVS_MODULE}"
+
+CRYSTAL_PREFIX="/opt/crystal-cvs"
+
+src_compile() {
+ ./configure --prefix=${CRYSTAL_PREFIX} || die "configure failed"
+ jam all || die "compile failed"
+}
+
+src_install() {
+ jam -sprefix="${D}"${CRYSTAL_PREFIX} install
+
+ # symlink for cs-config
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
+
+ # make sure these files dont have $D
+ dosed ${CRYSTAL_PREFIX}/{bin/cs-config,etc/crystalspace/vfs.cfg}
+
+ # fix perms so everyone can read these things
+ find "${D}"/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find "${D}"/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx "${D}"/${CRYSTAL_PREFIX}/bin/*
+
+ dodir /etc/env.d
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+ doconfd 90crystalspace
+}
diff --git a/dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.97 b/dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.99
index e69de29bb2d1..e69de29bb2d1 100644
--- a/dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.97
+++ b/dev-games/crystalspace-cvs/files/digest-crystalspace-cvs-0.99