summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-05-24 08:37:29 +0000
committerZac Medico <zmedico@gentoo.org>2015-05-24 08:37:29 +0000
commita4db9a50320e0d0e01020091282ccaa06e4a4ff9 (patch)
tree0d7aa9b5d4a94c3b2484556f8fa7048efafb16e7 /dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild
parentAdd workaround for TestLinking in display/dict_test.go. (diff)
downloadgentoo-2-a4db9a50320e0d0e01020091282ccaa06e4a4ff9.tar.gz
gentoo-2-a4db9a50320e0d0e01020091282ccaa06e4a4ff9.tar.bz2
gentoo-2-a4db9a50320e0d0e01020091282ccaa06e4a4ff9.zip
Disable broken tests.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild')
-rw-r--r--dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild101
1 files changed, 15 insertions, 86 deletions
diff --git a/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild b/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild
index 71e79251a0ea..741b96f487eb 100644
--- a/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild
+++ b/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild,v 1.1 2015/05/21 08:23:09 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-crypto/go-crypto-1.4.2_p20150514.ebuild,v 1.2 2015/05/24 08:37:29 zmedico Exp $
EAPI=5
@@ -26,6 +26,19 @@ src_unpack() {
mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
}
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' -i ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i ssh/test/session_test.go || die
+}
+
src_compile() {
# Create a writable GOROOT in order to avoid sandbox violations.
GOROOT="${WORKDIR}/goroot"
@@ -37,91 +50,7 @@ src_compile() {
src_test() {
GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
- go test -run "^"$(
- echo -n 'Example_usage|Test(AcceptClose|AgainstLibOTR|Agent|'
- echo -n 'Append|Append|AppendNoRealloc|Auth|Auth|'
- echo -n 'AuthMethodFallback|AuthMethodInvalidPublicKey|'
- echo -n 'AuthMethodKeyboardInteractive|AuthMethodPassword|'
- echo -n 'AuthMethodRSAandDSA|AuthMethodWrongKeyboardInteractive|'
- echo -n 'AuthMethodWrongPassword|AuthorizedKeyBasic|'
- echo -n 'AuthWithInvalidSpace|AuthWithMissingQuote|'
- echo -n 'AuthWithQuotedCommaInEnv|AuthWithQuotedQuoteInEnv|'
- echo -n 'AuthWithQuotedSpaceInEnv|AutoPortListenBroken|BadSMP|'
- echo -n 'BareMarshal|BareMarshalUnmarshal|BaseScalarMult|'
- echo -n 'Basic|BcryptingIsCorrect|BcryptingIsEasy|Bilinearity|'
- echo -n 'Blocksize|Box|BufferClose|BufferReadwrite|CampbellQuine|'
- echo -n 'CanonicalText|Cert|CertLogin|Cipher|CipherDecrypt|'
- echo -n 'CipherDecrypt|CipherEncrypt|CipherEncrypt|CipherInit|'
- echo -n 'Ciphers|ClientAuthPublicKey|ClientHandlesKeepalives|'
- echo -n 'ClientHMAC|ClientLoginCert|ClientUnsupportedCipher|'
- echo -n 'ClientUnsupportedKex|ClientWriteEOF|Close|Compressed|'
- echo -n 'Conversation|Core208|Cost|CostReturnsWithLeadingZeroes|'
- echo -n 'CostValidationInHash|CurveImpl|CustomClientVersion|'
- echo -n 'Debug|DecodeEncode|DecryptingEncryptedKey|'
- echo -n 'DefaultCiphersExist|DefaultClientVersion|'
- echo -n 'DetachedSignature|DetachedSignatureDSA|Dial|'
- echo -n 'DoubleClose|DSAHashTruncatation|Ecc384Serialize|'
- echo -n 'EncodeDecode|EncryptDecrypt|EncryptingEncryptedKey|'
- echo -n 'Encryption|ExchangeVersions|ExchangeVersionsBasic|'
- echo -n 'ExitSignalAndStatus|ExitStatusNonZero|ExitStatusZero|'
- echo -n 'ExitWithoutStatusOrSignal|ExternallyRevocableKey|Full|'
- echo -n 'G1Identity|G1Marshal|G2Identity|G2Marshal|GetKeyById|'
- echo -n 'GFp12Invert|GFp2Invert|GFp6Invert|Golden|GoodSMP|'
- echo -n 'HandshakeAutoRekeyRead|HandshakeAutoRekeyWrite|'
- echo -n 'HandshakeBasic|HandshakeError|HandshakeTwice|HKDF|'
- echo -n 'HKDFLimit|HKDFMultiRead|HostKeyCert|HostKeyCheck|'
- echo -n 'IdVerification|IntLength|InvalidEntry|'
- echo -n 'InvalidHashErrors|InvalidKeySize|'
- echo -n 'InvalidServerConfiguration|InvalidTerminalMode|'
- echo -n 'IsQuery|Iterated|KeccakKats|Kexes|Key|KeyExpiry|'
- echo -n 'KeyMarshalParse|KeyPresses|KeyRevocation|'
- echo -n 'KeySerialization|KeySignVerify|KeyUsage|'
- echo -n 'KnownExitSignalOnly|Limited|LockClient|LockServer|'
- echo -n 'LongHeader|MACs|MarshalParsePublicKey|MarshalPtr|'
- echo -n 'MarshalUnmarshal|MillionA|MinorNotRequired|'
- echo -n 'MissingHashFunction|MuxChannelCloseWriteUnblock|'
- echo -n 'MuxChannelExtendedThreadSafety|MuxChannelOverflow|'
- echo -n 'MuxChannelRequest|MuxChannelRequestUnblock|'
- echo -n 'MuxCloseChannel|MuxCloseWriteChannel|'
- echo -n 'MuxConnectionCloseWriteUnblock|MuxDisconnect|'
- echo -n 'MuxGlobalRequest|MuxGlobalRequestUnblock|'
- echo -n 'MuxInvalidRecord|MuxMaxPacketSize|MuxReadWrite|'
- echo -n 'MuxReject|NewEntity|NewPublicKey|NewUserId|'
- echo -n 'NewUserIdWithInvalidInput|NoArmoredData|'
- echo -n 'NoPermissionsPassing|OCFB|OCSPDecode|'
- echo -n 'OCSPDecodeWithoutCert|OCSPRequest|'
- echo -n 'OCSPResponse|OCSPSignature|OpaqueParseReason|OrderG1|'
- echo -n 'OrderG2|OrderGT|PacketCiphers|Parse|Parse|ParseCert|'
- echo -n 'ParseCertWithOptions|ParseDSA|ParseECPrivateKey|'
- echo -n 'ParseLibOTRPrivateKey|ParseRSAPrivateKey|'
- echo -n 'ParseUserAttribute|ParseUserId|ParseWithNoNewlineAtEnd|'
- echo -n 'PartialLengthReader|PartialLengths|PasswordNotSaved|'
- echo -n 'PermissionsPassing|PortForward|'
- echo -n 'PortForwardConnectionClose|PrivateKeyRead|'
- echo -n 'PublicKeyRead|PublicKeySerialize|PublicKeyV3Read|'
- echo -n 'PublicKeyV3Serialize|ReadDSAKey|ReadFull|ReadHeader|'
- echo -n 'ReadingArmoredPrivateKey|ReadingArmoredPublicKey|'
- echo -n 'ReadKeyRing|ReadLength|ReadPrivateKeyRing|ReadVersion|'
- echo -n 'ReadVersionError|RereadKeyRing|RunCommandFailed|Salsa20|'
- echo -n 'Salted|SaltedCipher|SaltedCipherKeyLength|Sbox|SealOpen|'
- echo -n 'SealOpen|SecretBox|Serialize|Serialize|SerializeHeader|'
- echo -n 'SerializeSymmetricKeyEncrypted|Server|ServerWindow|'
- echo -n 'SessionCombinedOutput|SessionID|SessionOutput|'
- echo -n 'SessionShell|SessionStdoutPipe|SetupForwardAgent|'
- echo -n 'SignatureRead|SignatureReserialize|SignatureV3Read|'
- echo -n 'SignatureV3Reserialize|SignDetached|SignDetachedDSA|'
- echo -n 'SignedEncryptedMessage|SignedMessage|Signing|'
- echo -n 'SignTextDetached|SignVerify|Squeezing|SubkeyRevocation|'
- echo -n 'Sum|SymmetricallyEncrypted|SymmetricEncryption|'
- echo -n 'SymmetricKeyEncrypted|TerminalSetSize|TextSignedMessage|'
- echo -n 'TooLongPasswordsWork|TransportMaxPacketReader|'
- echo -n 'TransportMaxPacketWrite|TripartiteDiffieHellman|'
- echo -n 'UnknownExitSignal|UnknownHashFunction|UnmarshalEmptyPacket|'
- echo -n 'UnmarshalUnexpectedPacket|UnpaddedBase64Encoding|'
- echo -n 'UnspecifiedRecipient|UnsupportedCurves|ValidateCert|'
- echo -n 'ValidateCertTime|Vectors|VeryShortPasswords|WithHMACSHA1|'
- echo -n 'WithHMACSHA256|XSalsa20|XTS|ZeroWindowAdjust)$') \
- -x -v ${GO_PN}/... || die $?
+ go test -x -v ${GO_PN}/... || die $?
}
src_install() {