summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 11:56:54 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 11:56:54 +0000
commit5c1c5e50db04c685518d70f13e374b903b84828d (patch)
tree3526dfb8c1694eebc615a28d5a17666d4aa185b5 /dev-haskell/atomic-primops
parentBump optparse-applicative to 0.7.0.2 (diff)
downloadgentoo-2-5c1c5e50db04c685518d70f13e374b903b84828d.tar.gz
gentoo-2-5c1c5e50db04c685518d70f13e374b903b84828d.tar.bz2
gentoo-2-5c1c5e50db04c685518d70f13e374b903b84828d.zip
Add atomic-primops
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/atomic-primops')
-rw-r--r--dev-haskell/atomic-primops/ChangeLog9
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild32
-rw-r--r--dev-haskell/atomic-primops/metadata.xml18
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/atomic-primops/ChangeLog b/dev-haskell/atomic-primops/ChangeLog
new file mode 100644
index 000000000000..074c95aa063f
--- /dev/null
+++ b/dev-haskell/atomic-primops/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/atomic-primops
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/atomic-primops/ChangeLog,v 1.1 2013/10/19 11:56:54 gienah Exp $
+
+*atomic-primops-0.4-r1 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +atomic-primops-0.4-r1.ebuild,
+ +metadata.xml:
+ Add atomic-primops
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild
new file mode 100644
index 000000000000..e9e0aa3fc6ea
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild,v 1.1 2013/10/19 11:56:54 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib haddock hoogle hscolour profile"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell."
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree-queue/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/bits-atomic:=[profile?]
+ dev-haskell/cabal:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.4.1:="
+DEPEND="${RDEPEND}
+ profile? ( !<dev-haskell/cabal-1.17 )
+ >=dev-haskell/cabal-1.8"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/atomic-primops/metadata.xml b/dev-haskell/atomic-primops/metadata.xml
new file mode 100644
index 000000000000..dfe72d2656bd
--- /dev/null
+++ b/dev-haskell/atomic-primops/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ After GHC 7.4 a new `casMutVar#` primop became available, but it&#39;s
+ difficult to use safely, because pointer equality is a highly
+ unstable property in Haskell. This library provides a safer method
+ based on the concept of &quot;Tickets&quot;.
+
+ Also, this library uses the &quot;foreign primop&quot; capability of GHC to
+ add access to other variants that may be of
+ interest, specifically, compare and swap inside an array.
+ </longdescription>
+</pkgmetadata>