summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-29 21:39:32 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-29 21:39:32 +0000
commit69222be0337ae0a161e893bec09230490e401130 (patch)
tree228da8aa97ea0b7ee8f9968cd00dc1316b0b86a3 /dev-haskell/c2hs/c2hs-0.16.0.ebuild
parentamd64 stable, bug #258867 (diff)
downloadgentoo-2-69222be0337ae0a161e893bec09230490e401130.tar.gz
gentoo-2-69222be0337ae0a161e893bec09230490e401130.tar.bz2
gentoo-2-69222be0337ae0a161e893bec09230490e401130.zip
Version bump dev-haskell/c2hs.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/c2hs/c2hs-0.16.0.ebuild')
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/c2hs/c2hs-0.16.0.ebuild b/dev-haskell/c2hs/c2hs-0.16.0.ebuild
new file mode 100644
index 000000000000..16fbff25d1fc
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.0.ebuild,v 1.1 2009/07/29 21:39:32 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.2
+ dev-haskell/filepath
+ >=dev-haskell/language-c-0.3.1.1
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}