summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 05:32:44 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 05:32:44 +0000
commitb61b96c01acd79d2d7d17dc7232029447e8480f0 (patch)
tree16a1b7c783446c73f60efd0539b8e39d01680206 /dev-haskell/c2hs
parentBump (diff)
downloadgentoo-2-b61b96c01acd79d2d7d17dc7232029447e8480f0.tar.gz
gentoo-2-b61b96c01acd79d2d7d17dc7232029447e8480f0.tar.bz2
gentoo-2-b61b96c01acd79d2d7d17dc7232029447e8480f0.zip
Bump c2hs to 0.16.5
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/c2hs')
-rw-r--r--dev-haskell/c2hs/ChangeLog7
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.5.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-haskell/c2hs/ChangeLog b/dev-haskell/c2hs/ChangeLog
index 3006ed41548f..b87b0648e7cc 100644
--- a/dev-haskell/c2hs/ChangeLog
+++ b/dev-haskell/c2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/c2hs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.62 2013/04/18 17:34:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/ChangeLog,v 1.63 2013/09/13 05:32:44 gienah Exp $
+
+*c2hs-0.16.5 (13 Sep 2013)
+
+ 13 Sep 2013; Mark Wright <gienah@gentoo.org> +c2hs-0.16.5.ebuild:
+ Bump c2hs to 0.16.5
18 Apr 2013; Agostino Sarubbo <ago@gentoo.org> c2hs-0.16.4.ebuild:
Stable for alpha, wrt bug #457270
diff --git a/dev-haskell/c2hs/c2hs-0.16.5.ebuild b/dev-haskell/c2hs/c2hs-0.16.5.ebuild
new file mode 100644
index 000000000000..80e2e29565b2
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.16.5.ebuild,v 1.1 2013/09/13 05:32:44 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.10.4
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/language-c-0.3.1.1
+ <dev-haskell/language-c-0.5
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}