summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:20:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-14 18:20:15 +0000
commitc2229b7a6e5b5f01b0eee626f0997bfa4ae4ec90 (patch)
tree531f3c98c169cfcdc3076e39872c4f9b79c1be22 /dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c2229b7a6e5b5f01b0eee626f0997bfa4ae4ec90.tar.gz
gentoo-2-c2229b7a6e5b5f01b0eee626f0997bfa4ae4ec90.tar.bz2
gentoo-2-c2229b7a6e5b5f01b0eee626f0997bfa4ae4ec90.zip
Version bump.
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild')
-rw-r--r--dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild b/dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild
new file mode 100644
index 000000000000..c4205e180c05
--- /dev/null
+++ b/dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal-install/cabal-install-1.18.0.2.ebuild,v 1.1 2013/11/14 18:20:15 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit bash-completion-r1 eutils haskell-cabal
+
+DESCRIPTION="The command-line interface for Cabal and Hackage."
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+noprefs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.0 <dev-haskell/cabal-1.19
+ >=dev-haskell/http-4000.0.8 <dev-haskell/http-4001
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3
+ >=dev-haskell/network-1 <dev-haskell/network-3
+ >=dev-haskell/random-1 <dev-haskell/random-1.1
+ >=dev-haskell/stm-2.0 <dev-haskell/stm-3
+ >=dev-haskell/zlib-0.5.3 <dev-haskell/zlib-0.6
+ >=dev-lang/ghc-6.12.1
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.3 )
+"
+
+src_prepare() {
+ if use noprefs; then
+ epatch "${FILESDIR}/${PN}"-0.13.3-nopref.patch
+ fi
+
+ # no chance to link to -threaded on ppc64, alpha and others
+ # who use UNREG, not only ARM
+ if ! ghc-supports-threaded-runtime; then
+ cabal_chdeps '-threaded' ' '
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ newbashcomp "${S}/bash-completion/cabal" ${PN}
+}