summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:04:58 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:04:58 +0000
commitb3f6082320417119901fd5da706f39062b3fb636 (patch)
tree78f5f10b321e8bfbe13b06e62715c6b127fee5c1 /dev-haskell/conduit
parentnew package (diff)
downloadgentoo-2-b3f6082320417119901fd5da706f39062b3fb636.tar.gz
gentoo-2-b3f6082320417119901fd5da706f39062b3fb636.tar.bz2
gentoo-2-b3f6082320417119901fd5da706f39062b3fb636.zip
new version
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/conduit')
-rw-r--r--dev-haskell/conduit/ChangeLog7
-rw-r--r--dev-haskell/conduit/conduit-1.0.15.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/conduit/ChangeLog b/dev-haskell/conduit/ChangeLog
index 512d695642b4..9e4150b7e74a 100644
--- a/dev-haskell/conduit/ChangeLog
+++ b/dev-haskell/conduit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/conduit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.7 2014/03/02 23:01:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.8 2014/03/04 16:04:58 qnikst Exp $
+
+*conduit-1.0.15.1 (04 Mar 2014)
+
+ 04 Mar 2014; Alexander Vershilov <qnikst@gentoo.org> +conduit-1.0.15.1.ebuild:
+ new version
02 Mar 2014; Pacho Ramos <pacho@gentoo.org> conduit-1.0.9.3.ebuild:
amd64 stable, bug #502662
diff --git a/dev-haskell/conduit/conduit-1.0.15.1.ebuild b/dev-haskell/conduit/conduit-1.0.15.1.ebuild
new file mode 100644
index 000000000000..b1e4b315649b
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.0.15.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/conduit-1.0.15.1.ebuild,v 1.1 2014/03/04 16:04:58 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library."
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="nohandles"
+
+RDEPEND=">=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/mmorph:=[profile?]
+ >=dev-haskell/monad-control-0.3.1:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/text-stream-decode-0.1.0.4:=[profile?] <dev-haskell/text-stream-decode-0.2:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag nohandles nohandles)
+}