summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 10:52:01 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 10:52:01 +0000
commit8450bfc434366e20e25d57c0794cb69c999e10d6 (patch)
treebd3a1b73a0ee72ad4ef3e2b9dcc9b46de23710c4 /dev-haskell/crypto-conduit
parentBump configfile to 1.1.4 (diff)
downloadgentoo-2-8450bfc434366e20e25d57c0794cb69c999e10d6.tar.gz
gentoo-2-8450bfc434366e20e25d57c0794cb69c999e10d6.tar.bz2
gentoo-2-8450bfc434366e20e25d57c0794cb69c999e10d6.zip
Bump crypto-conduit to 0.5.5
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/crypto-conduit')
-rw-r--r--dev-haskell/crypto-conduit/ChangeLog7
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-haskell/crypto-conduit/ChangeLog b/dev-haskell/crypto-conduit/ChangeLog
index e25d5cd9c051..f6a73e580c8c 100644
--- a/dev-haskell/crypto-conduit/ChangeLog
+++ b/dev-haskell/crypto-conduit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/crypto-conduit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/ChangeLog,v 1.6 2014/07/25 09:16:13 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/ChangeLog,v 1.7 2014/12/14 10:52:01 gienah Exp $
+
+*crypto-conduit-0.5.5 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +crypto-conduit-0.5.5.ebuild:
+ Bump crypto-conduit to 0.5.5
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org>
crypto-conduit-0.5.2.1.ebuild, crypto-conduit-0.5.2.2.ebuild,
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.5.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5.ebuild
new file mode 100644
index 000000000000..1e32aed62a8b
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/crypto-conduit-0.5.5.ebuild,v 1.1 2014/12/14 10:52:01 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)"
+HOMEPAGE="https://github.com/prowdsponsor/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conduit11"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ conduit11? ( >=dev-haskell/conduit-extra-1.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-api-0.13
+ >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit11 conduit11) \
+ --flag=-old-crypto-api
+}