summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-05-09 19:59:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-05-09 19:59:11 +0000
commit439d6b52458a6b727a1e31778411b63028fd6ea2 (patch)
treecb377bfcaec206c95465f002365b73deef60dfe8 /dev-haskell/glade/glade-0.12.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-439d6b52458a6b727a1e31778411b63028fd6ea2.tar.gz
gentoo-2-439d6b52458a6b727a1e31778411b63028fd6ea2.tar.bz2
gentoo-2-439d6b52458a6b727a1e31778411b63028fd6ea2.zip
Initial version. Haskell bindings for gnome-base/libglade.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/glade/glade-0.12.0.ebuild')
-rw-r--r--dev-haskell/glade/glade-0.12.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/glade/glade-0.12.0.ebuild b/dev-haskell/glade/glade-0.12.0.ebuild
new file mode 100644
index 000000000000..eabd21779897
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glade/glade-0.12.0.ebuild,v 1.1 2011/05/09 19:59:11 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell bindings to the gnome-base/libglade library."
+HOMEPAGE="http://www.haskell.org/gtk2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/cairo-0.12*
+ =dev-haskell/glib-0.12*
+ =dev-haskell/gtk-0.12*
+ dev-haskell/mtl
+ =dev-haskell/pango-0.12*
+ >=dev-lang/ghc-6.10.1
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools"