summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-05-13 16:02:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-05-13 16:02:06 +0000
commitec9d7787f616ed94a1e401b9700444646ce21f41 (patch)
tree03d4e93519a67fb073a7ab88ea4c5e52d725cc8a /dev-haskell/hashtables
parentVersion bump (ghc-7.4 support) (diff)
downloadgentoo-2-ec9d7787f616ed94a1e401b9700444646ce21f41.tar.gz
gentoo-2-ec9d7787f616ed94a1e401b9700444646ce21f41.tar.bz2
gentoo-2-ec9d7787f616ed94a1e401b9700444646ce21f41.zip
Version bump (ghc-7.4 support)
(Portage version: 2.2.0_alpha101_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hashtables')
-rw-r--r--dev-haskell/hashtables/ChangeLog8
-rw-r--r--dev-haskell/hashtables/hashtables-1.0.1.6.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-haskell/hashtables/ChangeLog b/dev-haskell/hashtables/ChangeLog
index 1c3d07b7a76b..54917188104b 100644
--- a/dev-haskell/hashtables/ChangeLog
+++ b/dev-haskell/hashtables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hashtables
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/ChangeLog,v 1.2 2012/04/14 10:30:36 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/ChangeLog,v 1.3 2012/05/13 16:02:06 slyfox Exp $
+
+*hashtables-1.0.1.6 (13 May 2012)
+
+ 13 May 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +hashtables-1.0.1.6.ebuild:
+ Version bump (ghc-7.4 support)
*hashtables-1.0.1.3 (14 Apr 2012)
diff --git a/dev-haskell/hashtables/hashtables-1.0.1.6.ebuild b/dev-haskell/hashtables/hashtables-1.0.1.6.ebuild
new file mode 100644
index 000000000000..1df5db202ba9
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.0.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/hashtables-1.0.1.6.ebuild,v 1.1 2012/05/13 16:02:06 slyfox Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="http://github.com/gregorycollins/hashtables"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1[profile?]
+ <dev-haskell/hashable-2[profile?]
+ dev-haskell/primitive[profile?]
+ >=dev-haskell/vector-0.7[profile?]
+ <dev-haskell/vector-0.10[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"