summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-05-29 09:53:56 +0000
committerMark Wright <gienah@gentoo.org>2012-05-29 09:53:56 +0000
commit34bd24341ff5aca5e0db7ccb90eaacbb37cadf0c (patch)
tree44c88cc758437a4e8571020f7283875d21481aee /dev-haskell/haskell-src-exts
parentAdd xarthisius' patch for bug #360513 to GRUB 0.97 patchset, reviewed by myse... (diff)
downloadgentoo-2-34bd24341ff5aca5e0db7ccb90eaacbb37cadf0c.tar.gz
gentoo-2-34bd24341ff5aca5e0db7ccb90eaacbb37cadf0c.tar.bz2
gentoo-2-34bd24341ff5aca5e0db7ccb90eaacbb37cadf0c.zip
Bump haskell-src-exts to 1.13.3
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/haskell-src-exts')
-rw-r--r--dev-haskell/haskell-src-exts/ChangeLog7
-rw-r--r--dev-haskell/haskell-src-exts/haskell-src-exts-1.13.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/haskell-src-exts/ChangeLog b/dev-haskell/haskell-src-exts/ChangeLog
index 0b3d1eac5628..ed7e0726f38b 100644
--- a/dev-haskell/haskell-src-exts/ChangeLog
+++ b/dev-haskell/haskell-src-exts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/haskell-src-exts
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.16 2012/04/22 13:21:18 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/ChangeLog,v 1.17 2012/05/29 09:53:56 gienah Exp $
+
+*haskell-src-exts-1.13.3 (29 May 2012)
+
+ 29 May 2012; Mark Wright <gienah@gentoo.org> +haskell-src-exts-1.13.3.ebuild:
+ Bump haskell-src-exts to 1.13.3
*haskell-src-exts-1.13.2 (22 Apr 2012)
diff --git a/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.3.ebuild b/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.3.ebuild
new file mode 100644
index 000000000000..6bd4a7e1cc40
--- /dev/null
+++ b/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src-exts/haskell-src-exts-1.13.3.ebuild,v 1.1 2012/05/29 09:53:56 gienah Exp $
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer"
+HOMEPAGE="http://code.haskell.org/haskell-src-exts"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cpphs-1.3
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy"
+
+src_prepare() {
+ # test suite is broken, expects the package to be already installed.
+ # this new Setup.hs will use the package inplice for tests
+ cp "${FILESDIR}/haskell-src-exts-1.10.2-Setup.hs" "${S}/Setup.hs" \
+ || die "Could not cp Setup.hs for tests"
+
+ # remove broken tests. they will fail if you expect them to pass, and pass
+ # if you expect them to fail...
+ rm "${S}/Test/examples/Unicode"{.hs,Syntax.hs} \
+ || die "Could not rm broken tests"
+}