summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 11:51:01 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-03-17 11:51:01 +0000
commit4f9e99dd10f3cded381bcc35924fc156c68ba107 (patch)
tree3017a5f4ac962e0cab1842359560ae8199eb7609 /dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild
parentAdd modular lib to ghc 6.6. See bug 151012 (diff)
downloadgentoo-2-4f9e99dd10f3cded381bcc35924fc156c68ba107.tar.gz
gentoo-2-4f9e99dd10f3cded381bcc35924fc156c68ba107.tar.bz2
gentoo-2-4f9e99dd10f3cded381bcc35924fc156c68ba107.zip
Add modular lib to ghc 6.6. See bug 151012
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild')
-rw-r--r--dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild b/dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild
new file mode 100644
index 000000000000..75d3e01d99a6
--- /dev/null
+++ b/dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src/haskell-src-1.0-r1.ebuild,v 1.1 2007/03/17 11:51:01 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal
+
+GHC_PV=6.6
+
+DESCRIPTION="Haskell source library"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.6"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"