summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:51:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-06-12 19:51:22 +0000
commit8ae845cf4f275d16238664ce3bbbde318a6c3d90 (patch)
tree758ad4e3b287ad8ea553409573fe11cddfb7432f /dev-haskell/hdbc-odbc
parentVersion bump. Requested by Christopher Howard (bug #367211). Removed old vers... (diff)
downloadgentoo-2-8ae845cf4f275d16238664ce3bbbde318a6c3d90.tar.gz
gentoo-2-8ae845cf4f275d16238664ce3bbbde318a6c3d90.tar.bz2
gentoo-2-8ae845cf4f275d16238664ce3bbbde318a6c3d90.zip
Version bump. Requested by Christopher Howard (bug #367211). Removed old versions.
(Portage version: 2.1.10.1/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hdbc-odbc')
-rw-r--r--dev-haskell/hdbc-odbc/ChangeLog13
-rw-r--r--dev-haskell/hdbc-odbc/files/hdbc-odbc-helper.h34
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild32
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-1.0.1.1.ebuild23
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-1.1.3.0.ebuild46
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-2.2.3.2.ebuild61
-rw-r--r--dev-haskell/hdbc-odbc/metadata.xml13
7 files changed, 81 insertions, 141 deletions
diff --git a/dev-haskell/hdbc-odbc/ChangeLog b/dev-haskell/hdbc-odbc/ChangeLog
index 69bf33279221..e491753bcf11 100644
--- a/dev-haskell/hdbc-odbc/ChangeLog
+++ b/dev-haskell/hdbc-odbc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/hdbc-odbc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.13 2010/07/12 13:16:28 slyfox Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.14 2011/06/12 19:51:22 slyfox Exp $
+
+*hdbc-odbc-2.2.3.2 (12 Jun 2011)
+
+ 12 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ -hdbc-odbc-1.0.0.0.ebuild, -hdbc-odbc-1.0.1.1.ebuild,
+ -hdbc-odbc-1.1.3.0.ebuild, +hdbc-odbc-2.2.3.2.ebuild,
+ -files/hdbc-odbc-helper.h, metadata.xml:
+ Version bump. Requested by Christopher Howard (bug #367211). Removed old
+ versions.
12 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
hdbc-odbc-1.1.3.0.ebuild:
diff --git a/dev-haskell/hdbc-odbc/files/hdbc-odbc-helper.h b/dev-haskell/hdbc-odbc/files/hdbc-odbc-helper.h
deleted file mode 100644
index a9e7fac9331f..000000000000
--- a/dev-haskell/hdbc-odbc/files/hdbc-odbc-helper.h
+++ /dev/null
@@ -1,34 +0,0 @@
-#ifdef mingw32_HOST_OS
-#include <windows.h>
-#endif
-#include <sql.h>
-
-extern int sqlSucceeded(SQLRETURN ret);
-extern SQLRETURN sqlFreeHandleEnv(SQLHANDLE hdl);
-
-typedef struct TAG_finalizeonce {
- void *encapobj;
- int refcount;
- int isfinalized;
- void *extrainfo;
- struct TAG_finalizeonce *parent;
-} finalizeonce;
-
-extern finalizeonce *wrapobjodbc(void *obj, finalizeonce *parentobj);
-extern finalizeonce *wrapobjodbc_extra(void *obj, void *extra,
- finalizeonce *parentobj);
-
-extern SQLRETURN sqlFreeHandleDbc_app(finalizeonce *res);
-extern void sqlFreeHandleDbc_finalizer(finalizeonce *res);
-
-extern void sqlFreeHandleSth_app(finalizeonce *res);
-extern void sqlFreeHandleSth_finalizer(finalizeonce *res);
-
-extern SQLINTEGER nullData;
-extern void *getSqlOvOdbc3(void);
-
-extern SQLRETURN disableAutoCommit(SQLHDBC conn);
-extern SQLRETURN simpleSqlTables(SQLHSTMT stmt);
-extern SQLRETURN simpleSqlColumns(SQLHSTMT stmt, SQLCHAR *tablename,
- SQLSMALLINT tnlen);
-
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
deleted file mode 100644
index e31542c40a41..000000000000
--- a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild,v 1.2 2007/10/31 13:00:38 dcoutts Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit base haskell-cabal versionator
-
-DESCRIPTION="ODBC database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/unixODBC-2.2"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- base_src_unpack
-
- # temp patch for missing #include. It seems different versions of
- # dev-db/unixODBC #include their headers in each other differently.
- sed -i 's/#include <sqlext.h>/#include <sqlext.h>\n#include <sqlucode.h>/' \
- "${S}/Database/HDBC/ODBC/TypeConv.hsc"
-}
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.1.1.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.1.1.ebuild
deleted file mode 100644
index 50eb12d1799a..000000000000
--- a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.1.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.1.1.ebuild,v 1.2 2007/10/31 13:00:38 dcoutts Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit base haskell-cabal versionator
-
-DESCRIPTION="ODBC database driver for HDBC"
-HOMEPAGE="http://quux.org/devel/hdbc/"
-SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- ~dev-haskell/hdbc-${hdbc_PV}
- >=dev-db/unixODBC-2.2"
-
-S="${WORKDIR}/${PN}"
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-1.1.3.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-1.1.3.0.ebuild
deleted file mode 100644
index c87e83547aa8..000000000000
--- a/dev-haskell/hdbc-odbc/hdbc-odbc-1.1.3.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-1.1.3.0.ebuild,v 1.3 2010/07/12 13:18:10 slyfox Exp $
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal versionator
-
-MY_PN=HDBC-odbc
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="ODBC database driver for HDBC"
-HOMEPAGE="http://software.complete.org/hdbc-odbc"
-SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-hdbc_PV=$(get_version_component_range 1-3)
-
-DEPEND=">=dev-lang/ghc-6.4.1
- dev-haskell/mtl
- =dev-haskell/hdbc-${hdbc_PV}*
- >=dev-db/unixODBC-2.2"
-
-S="${WORKDIR}/${MY_P}"
-
-CABAL_CONFIGURE_FLAGS="--constraint=base<4"
-
-src_unpack() {
- unpack ${A}
-
- cp "${FILESDIR}/hdbc-odbc-helper.h" "${S}/"
-
- cabal-mksetup
- echo "Extra-Libraries: odbc" >> "${S}/${MY_PN}.cabal"
- sed -i -e 's/GHC-Options: -O2 -Wall/GHC-Options: -fvia-C/' \
- -e '/^Extensions:/a \
- , ForeignFunctionInterface' \
- "${S}/${MY_PN}.cabal"
-
- if version_is_at_least "6.8" "$(ghc-version)"; then
- echo "GHC-Options: -XPatternSignatures" >> "${S}/${MY_PN}.cabal"
- fi
-}
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-2.2.3.2.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-2.2.3.2.ebuild
new file mode 100644
index 000000000000..168e90d593d5
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-2.2.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-2.2.3.2.ebuild,v 1.1 2011/06/12 19:51:22 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-odbc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ODBC driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-odbc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured ODBC
+
+hdbc_PV=$(get_version_component_range 1-2)
+
+RDEPEND=">=dev-lang/ghc-6.10
+ =dev-haskell/hdbc-${hdbc_PV}*
+ dev-haskell/mtl
+ dev-haskell/utf8-string
+ >=dev-db/unixODBC-2.2
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+ test? ( dev-haskell/convertible
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ dev-haskell/time
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc-odbc/metadata.xml b/dev-haskell/hdbc-odbc/metadata.xml
index 8c66906af531..398cee0b8192 100644
--- a/dev-haskell/hdbc-odbc/metadata.xml
+++ b/dev-haskell/hdbc-odbc/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ It is cross-platform and supports unixODBC on Unix/Linux/POSIX platforms
+ and Microsoft ODBC on Windows. It is also the preferred way to access
+ MySQL databases from Haskell.
+ </longdescription>
</pkgmetadata>