summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-03-11 21:31:06 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-03-11 21:31:06 +0000
commit46f023eb594e8cb02b86d2d9c2c7fe9801354b26 (patch)
treef6379d7d3ca66bc0e086a6f5262cf7112a6b7158 /dev-haskell/hsql/hsql-1.7.ebuild
parentVersion bump from upstream (diff)
downloadgentoo-2-46f023eb594e8cb02b86d2d9c2c7fe9801354b26.tar.gz
gentoo-2-46f023eb594e8cb02b86d2d9c2c7fe9801354b26.tar.bz2
gentoo-2-46f023eb594e8cb02b86d2d9c2c7fe9801354b26.zip
Add a patch by Bjorn Bringert to fix a problem found in the sqlite3 backend. See also bugs #98549 and #98551.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'dev-haskell/hsql/hsql-1.7.ebuild')
-rw-r--r--dev-haskell/hsql/hsql-1.7.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-haskell/hsql/hsql-1.7.ebuild b/dev-haskell/hsql/hsql-1.7.ebuild
index a24c302e55a0..8fb38388f205 100644
--- a/dev-haskell/hsql/hsql-1.7.ebuild
+++ b/dev-haskell/hsql/hsql-1.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/hsql-1.7.ebuild,v 1.6 2006/03/11 20:33:26 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/hsql-1.7.ebuild,v 1.7 2006/03/11 21:31:06 dcoutts Exp $
CABAL_FEATURES="lib haddock"
-inherit ghc-package haskell-cabal
+inherit base ghc-package haskell-cabal
DESCRIPTION="SQL bindings for Haskell"
HOMEPAGE="http://htoolkit.sourceforge.net/"
@@ -18,6 +18,13 @@ DEPEND=">=virtual/ghc-6.4.1"
S="${WORKDIR}/HSQL/HSQL"
+src_unpack() {
+ base_src_unpack
+
+ cd ${S}
+ epatch "${FILESDIR}/${P}-sqltext-to-int.patch"
+}
+
pkg_postinst () {
ghc-package_pkg_postinst