summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-04 12:44:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-04 12:44:56 +0000
commit79a9f2b91e9ac11c16733d3d2b04969f6111fd7c (patch)
tree35be23706c3ec031e9180e1c8d9999d8c9d280cd /dev-haskell/hsql/hsql-1.8.1.ebuild
parentmask net-fs/samba[ads,cluster] as it require some unsupported features (diff)
downloadgentoo-2-79a9f2b91e9ac11c16733d3d2b04969f6111fd7c.tar.gz
gentoo-2-79a9f2b91e9ac11c16733d3d2b04969f6111fd7c.tar.bz2
gentoo-2-79a9f2b91e9ac11c16733d3d2b04969f6111fd7c.zip
Version bump (ghc-7 compatible)
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hsql/hsql-1.8.1.ebuild')
-rw-r--r--dev-haskell/hsql/hsql-1.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/hsql/hsql-1.8.1.ebuild b/dev-haskell/hsql/hsql-1.8.1.ebuild
new file mode 100644
index 000000000000..ef015b48d68d
--- /dev/null
+++ b/dev-haskell/hsql/hsql-1.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql/hsql-1.8.1.ebuild,v 1.1 2011/08/04 12:44:56 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple library for database access from Haskell."
+HOMEPAGE="http://hackage.haskell.org/package/hsql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ elog "You will probably want to emerge one or more HSQL backend."
+ elog "These backends are available:"
+ elog " hsql-postgresql"
+ elog " hsql-mysql"
+ elog " hsql-sqlite"
+ elog " hsql-odbc"
+}