summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 10:24:46 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 10:24:46 +0000
commit3a27e4798012ad3156038e7833493478c394c1cf (patch)
treef347d479794a725a90e9b10eb0fab371336d1350 /dev-haskell/http-client
parentLoosen attoparsec dep in http-attoparsec-0.1.1-r1 (diff)
downloadgentoo-2-3a27e4798012ad3156038e7833493478c394c1cf.tar.gz
gentoo-2-3a27e4798012ad3156038e7833493478c394c1cf.tar.bz2
gentoo-2-3a27e4798012ad3156038e7833493478c394c1cf.zip
Bump http-client to 0.3.3.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/ChangeLog7
-rw-r--r--dev-haskell/http-client/http-client-0.3.3.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-haskell/http-client/ChangeLog b/dev-haskell/http-client/ChangeLog
index 8cfc25454da3..d13417366551 100644
--- a/dev-haskell/http-client/ChangeLog
+++ b/dev-haskell/http-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http-client
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.2 2014/03/09 12:45:49 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/ChangeLog,v 1.3 2014/07/02 10:24:46 gienah Exp $
+
+*http-client-0.3.3.2 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +http-client-0.3.3.2.ebuild:
+ Bump http-client to 0.3.3.2
*http-client-0.2.2.2 (09 Mar 2014)
diff --git a/dev-haskell/http-client/http-client-0.3.3.2.ebuild b/dev-haskell/http-client/http-client-0.3.3.2.ebuild
new file mode 100644
index 000000000000..774fe8c1b6a9
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.3.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-client/http-client-0.3.3.2.ebuild,v 1.1 2014/07/02 10:24:46 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages."
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/publicsuffixlist:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/async
+ dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"