summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-23 08:43:20 +0000
committerMark Wright <gienah@gentoo.org>2014-12-23 08:43:20 +0000
commitb067c6eb2ad88eb03cad81df51054f667f4f02e1 (patch)
treef52b0a19ac794735af1f50f01868f192c51d492d /dev-haskell/hxt
parentBump juicypixels to 3.2 (diff)
downloadgentoo-2-b067c6eb2ad88eb03cad81df51054f667f4f02e1.tar.gz
gentoo-2-b067c6eb2ad88eb03cad81df51054f667f4f02e1.tar.bz2
gentoo-2-b067c6eb2ad88eb03cad81df51054f667f4f02e1.zip
Bump hxt to 9.3.1.10
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/ChangeLog7
-rw-r--r--dev-haskell/hxt/hxt-9.3.1.10.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-haskell/hxt/ChangeLog b/dev-haskell/hxt/ChangeLog
index da716d28060e..891a605c5310 100644
--- a/dev-haskell/hxt/ChangeLog
+++ b/dev-haskell/hxt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hxt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.24 2014/12/13 14:36:52 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.25 2014/12/23 08:43:20 gienah Exp $
+
+*hxt-9.3.1.10 (23 Dec 2014)
+
+ 23 Dec 2014; Mark Wright <gienah@gentoo.org> +hxt-9.3.1.10.ebuild:
+ Bump hxt to 9.3.1.10
*hxt-9.3.1.9 (13 Dec 2014)
diff --git a/dev-haskell/hxt/hxt-9.3.1.10.ebuild b/dev-haskell/hxt/hxt-9.3.1.10.ebuild
new file mode 100644
index 000000000000..d3b968c0c167
--- /dev/null
+++ b/dev-haskell/hxt/hxt-9.3.1.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-9.3.1.10.ebuild,v 1.1 2014/12/23 08:43:20 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="http://www.fh-wedel.de/~si/HXmlToolbox/index.html"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?] <dev-haskell/binary-1:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/hxt-charproperties-9.1:=[profile?] <dev-haskell/hxt-charproperties-10:=[profile?]
+ >=dev-haskell/hxt-regex-xmlschema-9:=[profile?] <dev-haskell/hxt-regex-xmlschema-10:=[profile?]
+ >=dev-haskell/hxt-unicode-9.0.1:=[profile?] <dev-haskell/hxt-unicode-10:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}