summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-08 17:37:50 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-08 17:37:50 +0000
commitef3535b56e533d3c3f04efd1955f4b0816a3d407 (patch)
tree13e1a7ef0691d3c5c92724f2ae08875450ba2071 /dev-haskell/mtl/mtl-1.0.1.ebuild
parentNew version from ghc-6.6.1 extralibs collection. (diff)
downloadgentoo-2-ef3535b56e533d3c3f04efd1955f4b0816a3d407.tar.gz
gentoo-2-ef3535b56e533d3c3f04efd1955f4b0816a3d407.tar.bz2
gentoo-2-ef3535b56e533d3c3f04efd1955f4b0816a3d407.zip
New version from ghc-6.6.1 extralibs collection.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell/mtl/mtl-1.0.1.ebuild')
-rw-r--r--dev-haskell/mtl/mtl-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/mtl/mtl-1.0.1.ebuild b/dev-haskell/mtl/mtl-1.0.1.ebuild
new file mode 100644
index 000000000000..f11e22bb2db6
--- /dev/null
+++ b/dev-haskell/mtl/mtl-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0.1.ebuild,v 1.1 2007/07/08 17:37:50 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+GHC_PV=6.6.1
+
+DESCRIPTION="Monad transformer library"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
+src_unpack() {
+ unpack "${A}"
+ sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" ${S}/Setup.hs
+}