summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:36:10 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 11:36:10 +0000
commit0d72de1e10035a141645f21cbd16ce9ee96f3754 (patch)
tree74d710ec4d7347f25666cfcefb073e11d5247afb /dev-haskell/network-protocol-xmpp
parentdev-haskell/gsasl: initial layout (diff)
downloadgentoo-2-0d72de1e10035a141645f21cbd16ce9ee96f3754.tar.gz
gentoo-2-0d72de1e10035a141645f21cbd16ce9ee96f3754.tar.bz2
gentoo-2-0d72de1e10035a141645f21cbd16ce9ee96f3754.zip
dev-haskell/network-protocol-xmpp: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/network-protocol-xmpp')
-rw-r--r--dev-haskell/network-protocol-xmpp/ChangeLog10
-rw-r--r--dev-haskell/network-protocol-xmpp/metadata.xml11
-rw-r--r--dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.4.ebuild34
-rw-r--r--dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.5.ebuild34
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-haskell/network-protocol-xmpp/ChangeLog b/dev-haskell/network-protocol-xmpp/ChangeLog
new file mode 100644
index 000000000000..40d42f7eb1d7
--- /dev/null
+++ b/dev-haskell/network-protocol-xmpp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/network-protocol-xmpp
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-protocol-xmpp/ChangeLog,v 1.1 2013/08/26 11:36:10 qnikst Exp $
+
+*network-protocol-xmpp-0.4.5 (26 Aug 2013)
+*network-protocol-xmpp-0.4.4 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +network-protocol-xmpp-0.4.4.ebuild, +network-protocol-xmpp-0.4.5.ebuild:
+ dev-haskell/network-protocol-xmpp: initial layout
diff --git a/dev-haskell/network-protocol-xmpp/metadata.xml b/dev-haskell/network-protocol-xmpp/metadata.xml
new file mode 100644
index 000000000000..c0ec47d5931d
--- /dev/null
+++ b/dev-haskell/network-protocol-xmpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Client library for the XMPP protocol.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.4.ebuild b/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.4.ebuild
new file mode 100644
index 000000000000..53973fc45b24
--- /dev/null
+++ b/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.4.ebuild,v 1.1 2013/08/26 11:36:10 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Client library for the XMPP protocol."
+HOMEPAGE="https://john-millikin.com/software/haskell-xmpp/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/gnuidn-0.2*:=[profile?]
+ >=dev-haskell/gnutls-0.1.4:=[profile?]
+ <dev-haskell/gnutls-0.3:=[profile?]
+ =dev-haskell/gsasl-0.3*:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ =dev-haskell/monads-tf-0.1*:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.5.ebuild b/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.5.ebuild
new file mode 100644
index 000000000000..3d48c1b0f2fb
--- /dev/null
+++ b/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network-protocol-xmpp/network-protocol-xmpp-0.4.5.ebuild,v 1.1 2013/08/26 11:36:10 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Client library for the XMPP protocol."
+HOMEPAGE="https://john-millikin.com/software/haskell-xmpp/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/gnuidn-0.2*:=[profile?]
+ >=dev-haskell/gnutls-0.1.4:=[profile?]
+ <dev-haskell/gnutls-0.3:=[profile?]
+ =dev-haskell/gsasl-0.3*:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ =dev-haskell/monads-tf-0.1*:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"