summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-15 13:50:11 +0000
committerMark Wright <gienah@gentoo.org>2012-06-15 13:50:11 +0000
commit4c2368158982f82cb6383bcca497ecbf99675b30 (patch)
tree775c526fc3f78fc445128b729f657a2e119e19aa /dev-haskell/network/network-2.3.0.14.ebuild
parentModify FBSD patch to include update to ./configure script, bug #421069 (diff)
downloadgentoo-2-4c2368158982f82cb6383bcca497ecbf99675b30.tar.gz
gentoo-2-4c2368158982f82cb6383bcca497ecbf99675b30.tar.bz2
gentoo-2-4c2368158982f82cb6383bcca497ecbf99675b30.zip
Bump network to 2.3.0.14
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/network/network-2.3.0.14.ebuild')
-rw-r--r--dev-haskell/network/network-2.3.0.14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/network/network-2.3.0.14.ebuild b/dev-haskell/network/network-2.3.0.14.ebuild
new file mode 100644
index 000000000000..12227e8fa106
--- /dev/null
+++ b/dev-haskell/network/network-2.3.0.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-2.3.0.14.ebuild,v 1.1 2012/06/15 13:50:11 gienah Exp $
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal autotools
+
+DESCRIPTION="Low-level networking interface"
+HOMEPAGE="http://github.com/haskell/network"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-haskell/parsec[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( <dev-haskell/hunit-1.3[profile?]
+ <dev-haskell/test-framework-0.7[profile?]
+ <dev-haskell/test-framework-hunit-0.3[profile?]
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}/network-2.2.0.0-eat-configure-opts.patch"
+ eautoreconf
+ sed -e 's@test-framework < 0.6@test-framework < 0.7@' \
+ -e 's@bytestring < 0.10@bytestring < 1.0@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
+}
+
+src_configure() {
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}