summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 10:59:32 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 10:59:32 +0000
commitb9dd9a4a1a642c87a34043daf1e7ea11fbc113d1 (patch)
tree8dbb367499c5b4a733f18a951dbe8fa9f83c78a7 /dev-haskell/openglraw
parentAdd tensor, part of fix for bug #363977 (diff)
downloadgentoo-2-b9dd9a4a1a642c87a34043daf1e7ea11fbc113d1.tar.gz
gentoo-2-b9dd9a4a1a642c87a34043daf1e7ea11fbc113d1.tar.bz2
gentoo-2-b9dd9a4a1a642c87a34043daf1e7ea11fbc113d1.zip
Add openglraw, part of fix for bug #363977
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/openglraw')
-rw-r--r--dev-haskell/openglraw/ChangeLog10
-rw-r--r--dev-haskell/openglraw/metadata.xml26
-rw-r--r--dev-haskell/openglraw/openglraw-1.2.0.0.ebuild29
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/openglraw/ChangeLog b/dev-haskell/openglraw/ChangeLog
new file mode 100644
index 000000000000..65a9541b97de
--- /dev/null
+++ b/dev-haskell/openglraw/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/openglraw
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openglraw/ChangeLog,v 1.1 2012/06/02 10:59:32 gienah Exp $
+
+*openglraw-1.2.0.0 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +metadata.xml,
+ +openglraw-1.2.0.0.ebuild:
+ Add openglraw, part of fix for bug #363977
+
diff --git a/dev-haskell/openglraw/metadata.xml b/dev-haskell/openglraw/metadata.xml
new file mode 100644
index 000000000000..b29c4104ec2e
--- /dev/null
+++ b/dev-haskell/openglraw/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ OpenGLRaw is a raw Haskell binding for the OpenGL 3.2 graphics system and
+ lots of OpenGL extensions. It is basically a 1:1 mapping of OpenGL&#39;s C API,
+ intended as a basis for a nicer interface. OpenGLRaw offers access to all
+ necessary functions, tokens and types plus a general facility for loading
+ extension entries. The module hierarchy closely mirrors the naming structure
+ of the OpenGL extensions, making it easy to find the right module to import.
+ All API entries are loaded dynamically, so no special C header files are
+ needed for building this package. If an API entry is not found at runtime, a
+ userError is thrown.
+
+ OpenGL is the industry&#39;s most widely used and supported 2D and 3D graphics
+ application programming interface (API), incorporating a broad set of
+ rendering, texture mapping, special effects, and other powerful visualization
+ functions. For more information about OpenGL and its various extensions,
+ please see &lt;http://www.opengl.org/&gt;
+ and &lt;http://www.opengl.org/registry/&gt;.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/openglraw/openglraw-1.2.0.0.ebuild b/dev-haskell/openglraw/openglraw-1.2.0.0.ebuild
new file mode 100644
index 000000000000..78c7d2a7b7cc
--- /dev/null
+++ b/dev-haskell/openglraw/openglraw-1.2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openglraw/openglraw-1.2.0.0.ebuild,v 1.1 2012/06/02 10:59:32 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="OpenGLRaw"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A raw binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"