summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:35:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-20 14:35:43 +0000
commitfce1b92d2d425445d9e31a5df481722b36b62f34 (patch)
tree1957c9df1bbda4d5738a764579a57f0cb5c82d3f /dev-haskell/pandoc-citeproc
parentNew GeoIP.dat.gz (bug #491772 by Mark Tomich). (diff)
downloadgentoo-2-fce1b92d2d425445d9e31a5df481722b36b62f34.tar.gz
gentoo-2-fce1b92d2d425445d9e31a5df481722b36b62f34.tar.bz2
gentoo-2-fce1b92d2d425445d9e31a5df481722b36b62f34.zip
Initial commit. Supports using pandoc with citeproc.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/pandoc-citeproc')
-rw-r--r--dev-haskell/pandoc-citeproc/ChangeLog9
-rw-r--r--dev-haskell/pandoc-citeproc/metadata.xml35
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild65
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-citeproc/ChangeLog b/dev-haskell/pandoc-citeproc/ChangeLog
new file mode 100644
index 000000000000..b938b3a3a049
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/pandoc-citeproc
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.1 2013/11/20 14:35:43 slyfox Exp $
+
+*pandoc-citeproc-0.1.2.1 (20 Nov 2013)
+
+ 20 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +pandoc-citeproc-0.1.2.1.ebuild:
+ Initial commit. Supports using pandoc with citeproc.
diff --git a/dev-haskell/pandoc-citeproc/metadata.xml b/dev-haskell/pandoc-citeproc/metadata.xml
new file mode 100644
index 000000000000..c4e8363b55cd
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="bibutils">use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
+ <flag name="embed_data_files">Embed locale files into the library (needed for windows packaging)</flag>
+ <flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
+ <flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
+ <flag name="small_base">Choose the new smaller, split-up base package.</flag>
+ <flag name="unicode_collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
+ </use>
+ <longdescription>
+ The pandoc-citeproc library exports functions for
+ using the citeproc system with pandoc. It relies on
+ citeproc-hs, a library for rendering
+ bibliographic reference citations into a variety
+ of styles using a macro language called Citation
+ Style Language (CSL). More details on CSL can be
+ found here: &lt;http://citationstyles.org/&gt;.
+
+ Currently this package includes a copy of the citeproc-hs
+ code. When citeproc-hs is updated to be compatible,
+ this package will simply depend on citeproc-hs.
+
+ This package also contains two executables: pandoc-citeproc,
+ which works as a pandoc filter (pandoc &gt;= 1.12), and
+ biblio2yaml, which converts bibliographic databases to
+ a yaml format suitable for inclusion in pandoc YAML
+ metadata.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
new file mode 100644
index 000000000000..65120523a0a0
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild,v 1.1 2013/11/20 14:35:43 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Supports using pandoc with citeproc"
+HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
+
+RDEPEND=">=app-text/pandoc-1.12.0.2:=[profile?]
+ dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/json:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/tagsoup:=[profile?]
+ >=dev-haskell/texmath-0.6.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/yaml-0.8:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?] )
+ unicode_collation? ( dev-haskell/text-icu:=[profile?] )
+ !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( dev-haskell/aeson-pretty
+ >=dev-haskell/diff-0.3 )
+"
+
+src_configure() {
+ # workaround bug on ghc-7.6.3:
+ # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
+ # > stack overflow: use +RTS -K<size> to increase it
+ replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ $(cabal_flag small_base small_base) \
+ $(cabal_flag unicode_collation unicode_collation)
+}