summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 10:26:03 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 10:26:03 +0000
commitb4f072e3adb8ee948b7d2714b842ccc76edc5157 (patch)
treeea1aa64e8330c2621026525ecbc953488e1b06d4 /dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
parentUpdate permission fixing code. Per bug #266432. (diff)
downloadgentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.tar.gz
gentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.tar.bz2
gentoo-2-b4f072e3adb8ee948b7d2714b842ccc76edc5157.zip
Version bump dev-haskell/quickcheck
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
new file mode 100644
index 000000000000..fa0cec764904
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.2.0.0.ebuild,v 1.1 2009/04/19 10:26:03 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://www.math.chalmers.se/~rjmh/QuickCheck/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"