summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:50:01 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:50:01 +0000
commit39b1f6bd30e1f625655b690c2505007a3c2f4117 (patch)
tree60a773f637a54b87d3b0b4db1b693ab9c25649b8 /dev-haskell/wai-extra
parentBump wai-app-static to 2.0.0.1 (diff)
downloadgentoo-2-39b1f6bd30e1f625655b690c2505007a3c2f4117.tar.gz
gentoo-2-39b1f6bd30e1f625655b690c2505007a3c2f4117.tar.bz2
gentoo-2-39b1f6bd30e1f625655b690c2505007a3c2f4117.zip
Bump wai-extra to 2.0.0.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/wai-extra')
-rw-r--r--dev-haskell/wai-extra/ChangeLog7
-rw-r--r--dev-haskell/wai-extra/wai-extra-2.0.0.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-haskell/wai-extra/ChangeLog b/dev-haskell/wai-extra/ChangeLog
index de39ae572d4a..fb23b5542782 100644
--- a/dev-haskell/wai-extra/ChangeLog
+++ b/dev-haskell/wai-extra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wai-extra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-extra/ChangeLog,v 1.2 2013/09/13 06:42:03 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-extra/ChangeLog,v 1.3 2013/12/11 06:50:01 gienah Exp $
+
+*wai-extra-2.0.0.1 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +wai-extra-2.0.0.1.ebuild:
+ Bump wai-extra to 2.0.0.1
*wai-extra-1.3.4.5 (13 Sep 2013)
diff --git a/dev-haskell/wai-extra/wai-extra-2.0.0.1.ebuild b/dev-haskell/wai-extra/wai-extra-2.0.0.1.ebuild
new file mode 100644
index 000000000000..1cd44dea2598
--- /dev/null
+++ b/dev-haskell/wai-extra/wai-extra-2.0.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-extra/wai-extra-2.0.0.1.ebuild,v 1.1 2013/12/11 06:50:01 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Provides some basic WAI handlers and middleware."
+HOMEPAGE="http://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/ansi-terminal:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-conduit-0.5:=[profile?] <dev-haskell/blaze-builder-conduit-1.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/fast-logger-2.0:=[profile?] <dev-haskell/fast-logger-2.1:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/network-2.2.1.5:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/stringsearch-0.3:=[profile?] <dev-haskell/stringsearch-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?]
+ >=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.1:=[profile?]
+ >=dev-haskell/wai-logger-2.0:=[profile?] <dev-haskell/wai-logger-2.1:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-haskell/zlib-conduit-0.5:=[profile?] <dev-haskell/zlib-conduit-1.1:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ >=dev-haskell/wai-test-1.3
+ dev-haskell/zlib
+ dev-haskell/zlib-bindings )
+"