summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-27 02:58:09 +0000
committerMark Wright <gienah@gentoo.org>2012-12-27 02:58:09 +0000
commit6af69df2b5d3850cd78ba9f67775ce1d13749181 (patch)
tree822ced165516f0677efbbd71be54284c043c5069 /dev-haskell/wxcore
parentBump wxhaskell to 0.13.2.1 and 0.90 (diff)
downloadgentoo-2-6af69df2b5d3850cd78ba9f67775ce1d13749181.tar.gz
gentoo-2-6af69df2b5d3850cd78ba9f67775ce1d13749181.tar.bz2
gentoo-2-6af69df2b5d3850cd78ba9f67775ce1d13749181.zip
Bump wxcore to 0.13.2.1 and 0.90.0.3
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/wxcore')
-rw-r--r--dev-haskell/wxcore/ChangeLog11
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch53
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch29
-rw-r--r--dev-haskell/wxcore/metadata.xml14
-rw-r--r--dev-haskell/wxcore/wxcore-0.12.1.6.ebuild27
-rw-r--r--dev-haskell/wxcore/wxcore-0.13.2.1.ebuild36
-rw-r--r--dev-haskell/wxcore/wxcore-0.90.0.3.ebuild36
7 files changed, 174 insertions, 32 deletions
diff --git a/dev-haskell/wxcore/ChangeLog b/dev-haskell/wxcore/ChangeLog
index 70a538e53e0f..b0e853c4922d 100644
--- a/dev-haskell/wxcore/ChangeLog
+++ b/dev-haskell/wxcore/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-haskell/wxcore
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.3 2012/12/07 10:35:21 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.4 2012/12/27 02:58:09 gienah Exp $
+
+*wxcore-0.90.0.3 (27 Dec 2012)
+*wxcore-0.13.2.1 (27 Dec 2012)
+
+ 27 Dec 2012; Mark Wright <gienah@gentoo.org>
+ +files/wxcore-0.13.2.1-ghc-7.6.patch, +files/wxcore-0.90.0.1-ghc-7.5.patch,
+ +wxcore-0.13.2.1.ebuild, +wxcore-0.90.0.3.ebuild, -wxcore-0.12.1.6.ebuild,
+ metadata.xml:
+ Bump wxcore to 0.13.2.1 and 0.90.0.3
07 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> wxcore-0.12.1.6.ebuild:
Get rid of 'dev-haskell/time' depend as it's a ghc's core library.
diff --git a/dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch b/dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch
new file mode 100644
index 000000000000..efc2c7b97a2f
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.13.2.1-ghc-7.6.patch
@@ -0,0 +1,53 @@
+--- wxcore-0.13.2.1-orig/wxcore.cabal 2012-02-07 18:27:09.000000000 +1100
++++ wxcore-0.13.2.1/wxcore.cabal 2012-11-29 17:21:49.458155692 +1100
+@@ -209,7 +209,7 @@
+ build-depends:
+ array >= 0.2 && < 0.5,
+ base >= 4 && < 5,
+- containers >= 0.2 && < 0.5
++ containers >= 0.2 && < 0.6
+ else
+ build-depends:
+ array >= 0.1 && < 0.3,
+--- wxcore-0.13.2.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-02-07 18:27:09.000000000 +1100
++++ wxcore-0.13.2.1/src/haskell/Graphics/UI/WXCore/Events.hs 2012-11-29 17:21:49.458155692 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -240,6 +240,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
+--- wxcore-0.13.2.1-orig/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-02-07 18:27:09.000000000 +1100
++++ wxcore-0.13.2.1/src/haskell/Graphics/UI/WXCore/WxcTypes.hs 2012-11-29 17:42:22.477244493 +1100
+@@ -142,7 +142,12 @@
+
+ import Data.Int
+ import Data.Word
++#ifdef MIN_VERSION_base(4,5,0)
++import Debug.Trace (traceIO)
++#else
+ import Debug.Trace (putTraceMsg)
++#define traceIO putTraceMsg
++#endif
+
+ import Graphics.UI.WXCore.WxcObject
+ import Graphics.UI.WXCore.WxcClassTypes
+@@ -853,7 +858,7 @@
+ withCharResult io
+ = do x <- io
+ if (x < 0)
+- then do putTraceMsg ("Recieved negative unicode: " ++ (show x))
++ then do traceIO ("Recieved negative unicode: " ++ (show x))
+ return '\n'
+ else return (fromCWchar x)
+
diff --git a/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch b/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch
new file mode 100644
index 000000000000..08f0f5bc27d2
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.90.0.1-ghc-7.5.patch
@@ -0,0 +1,29 @@
+--- wxcore-0.90.0.1-orig/wxcore.cabal 2012-05-15 06:26:55.000000000 +1000
++++ wxcore-0.90.0.1/wxcore.cabal 2012-05-19 21:32:01.230849131 +1000
+@@ -80,7 +80,7 @@
+ build-depends:
+ array >= 0.2 && < 0.5,
+ base >= 4 && < 5,
+- containers >= 0.2 && < 0.5
++ containers >= 0.2 && < 0.6
+ else
+ build-depends:
+ array >= 0.1 && < 0.3,
+--- wxcore-0.90.0.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2012-05-15 06:26:55.000000000 +1000
++++ wxcore-0.90.0.1/src/haskell/Graphics/UI/WXCore/Events.hs 2012-05-19 21:44:09.457185166 +1000
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -245,6 +245,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
diff --git a/dev-haskell/wxcore/metadata.xml b/dev-haskell/wxcore/metadata.xml
index 8c66906af531..015361853a6e 100644
--- a/dev-haskell/wxcore/metadata.xml
+++ b/dev-haskell/wxcore/metadata.xml
@@ -1,8 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ wxHaskell is a portable and native GUI library for Haskell. It is
+ built on top of wxWidgets, a comprehensive C++ library that is
+ portable across all major GUI platforms, including GTK, Windows,
+ X11, and MacOS X. This version works with wxWidgets 2.8 only.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild b/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild
deleted file mode 100644
index 95d55de88d11..000000000000
--- a/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild,v 1.3 2012/12/07 10:35:21 slyfox Exp $
-
-EAPI="2"
-
-WX_GTK_VER="2.8"
-
-CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal wxwidgets
-
-DESCRIPTION="wxHaskell core"
-HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/parsec
- dev-haskell/stm
- >=dev-haskell/wxdirect-0.12.1.3
- >=dev-lang/ghc-6.10
- x11-libs/wxGTK:2.8[X]"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2"
diff --git a/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild b/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild
new file mode 100644
index 000000000000..ac9c2ca759d1
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.13.2.1.ebuild,v 1.1 2012/12/27 02:58:09 gienah Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal wxwidgets
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="opengl"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >dev-haskell/wxdirect-0.12.1.2:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl?]"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.13.2.1-ghc-7.6.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+}
diff --git a/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
new file mode 100644
index 000000000000..1160e775da6d
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild,v 1.1 2012/12/27 02:58:09 gienah Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="opengl"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxc-0.90.0.4:${WX_GTK_VER}=[opengl,profile?]
+ >=dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.90.0.1-ghc-7.5.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+}