summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-23 15:03:50 +0000
committerMark Wright <gienah@gentoo.org>2014-03-23 15:03:50 +0000
commit820dc61ac44e9569cfa356271b5699658c25890b (patch)
tree9a3caca0883e0c07a78615be6bd968b31749d26a /dev-haskell/wxcore
parentBump wxc to 0.90.1.1 (diff)
downloadgentoo-2-820dc61ac44e9569cfa356271b5699658c25890b.tar.gz
gentoo-2-820dc61ac44e9569cfa356271b5699658c25890b.tar.bz2
gentoo-2-820dc61ac44e9569cfa356271b5699658c25890b.zip
Bump wxcore to 0.90.1.1, loosen array dep in 0.13.2.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/wxcore')
-rw-r--r--dev-haskell/wxcore/ChangeLog11
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch18
-rw-r--r--dev-haskell/wxcore/wxcore-0.13.2.3.ebuild6
-rw-r--r--dev-haskell/wxcore/wxcore-0.90.1.1.ebuild48
4 files changed, 79 insertions, 4 deletions
diff --git a/dev-haskell/wxcore/ChangeLog b/dev-haskell/wxcore/ChangeLog
index b0be879a6ec1..19b750a5085b 100644
--- a/dev-haskell/wxcore/ChangeLog
+++ b/dev-haskell/wxcore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/wxcore
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.5 2013/01/13 11:57:38 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.6 2014/03/23 15:03:49 gienah Exp $
+
+*wxcore-0.90.1.1 (23 Mar 2014)
+
+ 23 Mar 2014; Mark Wright <gienah@gentoo.org>
+ +files/wxcore-0.90.1.1-ghc-7.5.patch, +wxcore-0.90.1.1.ebuild,
+ wxcore-0.13.2.3.ebuild:
+ Bump wxcore to 0.90.1.1, loosen array dep in 0.13.2.3
*wxcore-0.13.2.3 (13 Jan 2013)
diff --git a/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch b/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch
new file mode 100644
index 000000000000..ee2405dce90e
--- /dev/null
+++ b/dev-haskell/wxcore/files/wxcore-0.90.1.1-ghc-7.5.patch
@@ -0,0 +1,18 @@
+--- wxcore-0.90.1.1-orig/src/haskell/Graphics/UI/WXCore/Events.hs 2014-03-23 08:01:17.000000000 +1100
++++ wxcore-0.90.1.1/src/haskell/Graphics/UI/WXCore/Events.hs 2014-03-23 17:05:26.428738461 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ForeignFunctionInterface #-}
++{-# LANGUAGE CPP, ForeignFunctionInterface #-}
+ -----------------------------------------------------------------------------------------
+ {-| Module : Events
+ Copyright : (c) Daan Leijen 2003
+@@ -248,6 +248,9 @@
+ import Foreign.Marshal.Alloc
+ import Foreign.Marshal.Array
+ import Foreign.Marshal.Utils
++#if (__GLASGOW_HASKELL__>=705)
++import Foreign.C.Types(CInt(..))
++#endif
+
+ import Data.Char ( chr ) -- used in stc
+ import Data.Maybe ( fromMaybe, fromJust )
diff --git a/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild b/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild
index 6941e02da136..36fc6f67d39b 100644
--- a/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild
+++ b/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild,v 1.1 2013/01/13 11:57:38 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.13.2.3.ebuild,v 1.2 2014/03/23 15:03:49 gienah Exp $
EAPI=5
@@ -34,6 +34,8 @@ src_prepare() {
sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
-i "${S}/Setup.hs" \
|| die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+ cabal_chdeps \
+ 'array >= 0.2 && < 0.5' 'array >= 0.2'
}
src_configure() {
diff --git a/dev-haskell/wxcore/wxcore-0.90.1.1.ebuild b/dev-haskell/wxcore/wxcore-0.90.1.1.ebuild
new file mode 100644
index 000000000000..82fac84c12d5
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.90.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.90.1.1.ebuild,v 1.1 2014/03/23 15:03:49 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal wxwidgets
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxc-0.90.1.0:${WX_GTK_VER}=[profile?]
+ >=dev-haskell/wxdirect-0.90.1.0:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+PATCHES=("${FILESDIR}/${PN}-0.90.1.1-ghc-7.5.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+ cabal_chdeps \
+ 'array >= 0.2 && < 0.5' 'array >= 0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}