summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-12-30 20:27:06 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-12-30 20:27:06 +0000
commit074f2a5fc96ee0751696a05f2ab5c690bf9ea3b0 (patch)
treefdff388036044d20b95173509ab3162e6b21a6dd /dev-haskell
parentBumb (diff)
downloadgentoo-2-074f2a5fc96ee0751696a05f2ab5c690bf9ea3b0.tar.gz
gentoo-2-074f2a5fc96ee0751696a05f2ab5c690bf9ea3b0.tar.bz2
gentoo-2-074f2a5fc96ee0751696a05f2ab5c690bf9ea3b0.zip
Version bump to dev-haskell/haxml
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haxml/ChangeLog8
-rw-r--r--dev-haskell/haxml/files/digest-haxml-1.13.33
-rw-r--r--dev-haskell/haxml/haxml-1.13.3.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-haskell/haxml/ChangeLog b/dev-haskell/haxml/ChangeLog
index d52d535dcb8a..37ff125f97b2 100644
--- a/dev-haskell/haxml/ChangeLog
+++ b/dev-haskell/haxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haxml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.27 2007/12/13 17:57:57 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.28 2007/12/30 20:27:06 kolmodin Exp $
+
+*haxml-1.13.3 (30 Dec 2007)
+
+ 30 Dec 2007; Lennart Kolmodin <kolmodin@gentoo.org> +haxml-1.13.3.ebuild:
+ Version bump. Mostly fixes to the build system, which we have to patch
+ anyway. This fixes bug #203800.
13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> haxml-1.13.2.ebuild:
Fixes for compatability with cabal-1.2 and ghc-6.8.
diff --git a/dev-haskell/haxml/files/digest-haxml-1.13.3 b/dev-haskell/haxml/files/digest-haxml-1.13.3
new file mode 100644
index 000000000000..9b0727511f08
--- /dev/null
+++ b/dev-haskell/haxml/files/digest-haxml-1.13.3
@@ -0,0 +1,3 @@
+MD5 63c773f75d3f067824e42fcaf89af024 HaXml-1.13.3.tar.gz 472660
+RMD160 4ea350b7d1af47188bc2839d9635297db01475e0 HaXml-1.13.3.tar.gz 472660
+SHA256 60872bc3684f6884e4b8fdfca95adf455072e8dc1f74105a33a6a69781e7a921 HaXml-1.13.3.tar.gz 472660
diff --git a/dev-haskell/haxml/haxml-1.13.3.ebuild b/dev-haskell/haxml/haxml-1.13.3.ebuild
new file mode 100644
index 000000000000..3d73466da645
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.13.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.13.3.ebuild,v 1.1 2007/12/30 20:27:06 kolmodin Exp $
+
+CABAL_FEATURES="lib bin profile haddock"
+inherit haskell-cabal versionator
+
+MY_PN="HaXml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Utilities for manipulating XML documents"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/HaXml/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack "${A}"
+
+ # Don't warn so much, and don't compile with -O2
+ sed -i 's/GHC-Options: -Wall -O2/GHC-Options: -O/' "${S}/HaXml.cabal"
+
+ # Unless ghc 6.8, remove the new packages
+ if ! version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e 's/, pretty, containers//' \
+ "${S}/HaXml.cabal"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ dodoc docs/icfp99.dvi docs/icfp99.ps.gz
+ fi
+}